Help Longing in

hosting

#1


Hi,
I am running Ubuntu 17.10 Desktop. I installed owncloud on my local PC. I used the instruction on this link (http://bit.ly/2Az9zRq) when I try and access owncloud from the PC that it is installed on ( using ether the browser or desktop client) it works fine. Likewise when I access it from any computer on the local network it also works fine. However, when I try and access it from anywhere over the Internet it will not connect. when I try through the Android app I receive the massage "The server too too long to respond" when I try by way of the browser I receive the message "Firefox can’t establish a connection to the server at 10.1.10.10."

I am not sure but I think I may know where the problem lies but I am not sure how to fix it. I will explain it below.

When I was installing owncloud I came to the part where it asked for my "ServerName ipaddress" I typed in the terminal "ifconfig" to get my IP address here is what the terminal reported:

server@Work:~$ ifconfig
enp5s0: flags=4163 mtu 1500
inet 10.1.10.10 netmask 255.255.255.0 broadcast 10.1.10.255
inet6 fe80::25fe:d4f7:78c1:e421 prefixlen 64 scopeid 0x20
ether 00:22:19:34:e9:19 txqueuelen 1000 (Ethernet)
RX packets 71126567 bytes 101429259802 (101.4 GB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 34400514 bytes 2853980331 (2.8 GB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 17

lo: flags=73 mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 421541 bytes 72598934 (72.5 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 421541 bytes 72598934 (72.5 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

I would add that as far as web address I did not know what to put in for "http://example.com/" so I did not change it. When I try and assesses it I just type in "10.1.10.10/index.php" also tried "https;//10.1.10.10/index.php" still it did not work

---------------
*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/...
NO

Are you using encryption: yes/no
NO

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/...
NO

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

Browser:

Operating system:

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...

#2

Hi,

can you sum up your problem into a question?

I have tried to find a question but could not find one.

What exactly is the issue?


#3

I can't log into owncloud from anywhere over the Internet.


#4

Does anywhere include from your local network?

Or can you just not login from "outside" your LAN?

Do you have an public IP address?

10.1.10.10 looks to me like one from the private address pool.


#5

Yes, I can login from the local network. My public IP is 23.30.15.126. That's what I get when I go to "https://whatismyipaddress.com/".


#6

Okay, have you configured your router to redirect from your public IP to your owncloud installation?

It seems to me that this is a networking issue, not an owncloud issue, am I wrong?


#7

Can I just change the local Ip 10.1.10.10 in my owncloud setting over to my public IP is 23.30.??.????


#8

I don't think so, the public IP ( which you should hide and don't post in a public forum, for security reasons) is the IP of your router which has been given to you by your ISP ( internet service provider ) you can't just give this IP to another device. What you can do is say to the router - if someone wants to access this ip with the http protocol, go to this private ip (10.1.10.10) on port 80 for http or port 443 for https( for this to work you will need a certificate)

You also have to enter the public and private IP in your config.php under trusted domains.

Again, this seems like a networking issue.


#9

How would I enter the public and private IP in your config.php under trusted domains?
Thanks


#10

here is a link to our doc :slight_smile:

https://doc.owncloud.com/server/10.0/admin_manual/configuration/server/config_sample_php_parameters.html?highlight=config#default-parameters