Help: problem with resetting/reinstalling owncloud 804 on QNAP

80x-older-eol
qnap
nas
help

#1

Hi
I've installed owncloud from app center.
I've configured owncloud but after a while i could not access it.
I've uninstalled/reinstalled owncloud but i don't get the configuration wizard - instead i get a user/password login request.
I've tried to use all the passwords/default passwords i could think of but i could not get access.

I've tried to reset password with " /mnt/ext/opt/apache/bin/php /share/Web/owncloud/occ user:resetpassword admin " command
but I got this result:
An unhandled exception has been thrown:
exception 'Exception' with message 'Not installed' in /share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud/lib/base.php:223
Stack trace:

0 /share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud/lib/base.php(558): OC::checkInstalled()

1 /share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud/lib/base.php(1039): OC::init()

2 /share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud/console.php(12): require_once('/share/CACHEDEV...')

3 /share/CACHEDEV1_DATA/.qpkg/owncloud/owncloud/occ(11): require_once('/share/CACHEDEV...')

4 {main}{"reqId":"4ecead96f746af2423b666cc1383a1a3","remoteAddr":"","app":"PHP","message":"touch(): Unable to create file \/share\/CACHEDEV1_DATA\/.qpkg\/owncloud\/owncloud\/data\/owncloud.log because No such file or directory at \/share\/CACHEDEV1_DATA\/.qpkg\/owncloud\/owncloud\/lib\/private\/log\/owncloud.php#48","level":3,"time":"2016-08-27T17:05:14+00:00"}

my question is: how can i truly reset owncloud or how could i reset admin password even though the configuration wizard can not run?

thanks a lot.
Tamir


#2

Try to install the package completely with all data (ask some QNAP experts how to do this). You can check after that, if it has really been removed if you can't find anything here:
/share/Web/owncloud and in your database.

Then install it again.


#3

Thanks for your response.
I've already removed and installed several times. each time i confirmed that /share/Web/owncloud is deleted completely. It seems there is some were else that owncloud has information other then /share/Web/owncloud and it is not deleted upon uninstalling, and it caused the startup wizard not to run and I also can not login.

this is what i'm looking for.... what to delete in order to bring owncloud to a clean state as it is on a real first install.

thanks
Tamir.


#4

You will have to ask the QNAP community how the packet manager there works, we can't help you here.

If you want to gain access, you can try to reset your password (if you have put an e-mail address to your account). If you haven't set an e-mail address, you can do it manually in your database. Insert into your oc_preferences database:

userid -> username
appid -> settings
configkey -> email
configvalue ->username@example.org