How can there be so many files that failed Integrity check?

9.0.x
help

#1

After doing a virgin upgrade to 9.0.4, there are all the files below that failed the integrity check. How is this possible? Shouldn't a virgin install of a non-dot-zero release be more stable?

I'm probably missing something, but I don't want to spend hours trying to fix all this.

Just wondering...

  • m

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results

  • core
    • INVALID_HASH
      • core/doc/admin/_sources/configuration_files/collaborative_documents_configuration.txt
      • core/doc/admin/_static/img/note_pencil.svg
      • core/doc/admin/_static/img/warning.svg
      • core/doc/admin/_static/style.css
      • core/fonts/LICENSE.txt
      • core/vendor/jquery-migrate/jquery-migrate.js
      • core/vendor/jquery-migrate/jquery-migrate.min.js
      • core/vendor/jsTimezoneDetect/jstz.js
  • files_external
    • INVALID_HASH
      • 3rdparty/Dropbox/API.php
  • files_texteditor
    • INVALID_HASH
      • js/vendor/ace/src-noconflict/mode-diff.js

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[core/doc/admin/_sources/configuration_files/collaborative_documents_configuration.txt] => Array
(
[expected] => 251befed4a319c8e4b390b363a9bc8079b54991891204a4ff1cb551797931ba9f276903e1e5e8bde932afcb5e67d23f7939cea22e68c6bd7695e2b8ce654c5b3
[current] => 637ac6c02e3ef06cc19a9b465c5c0e6ae6777f9e5d5d52cae28482f350e3b348a5c3ba67ae693e95971373c326af98c27c7f04492aa836b6ab1348f7341ccb29
)

                [core/doc/admin/_static/img/note_pencil.svg] => Array
                    (
                        [expected] => 78b9df57afe9468145e6e375cd1f61274b269b9c3019726a99e043ae952367acf53cf471cbc5b3dcca2e68367c2c4422d4a9f9a9fdbb11f9b962845ac77857de
                        [current] => 97117ce2827cc1b742678b52fc100de1e7d3fdb1adeea04a301c012e7f95b66e10a369c6a83ba89a707c4232b5e31fba3d5e58b0e0d970f22031d0704eebb5a9
                    )

                [core/doc/admin/_static/img/warning.svg] => Array
                    (
                        [expected] => e8647b47ef1531b8c2fcdd51f76996fe85476467fc694540f3dcf8ce7e7da489e99edae5a158742da71c07dc09ccfaf721f01c1c4bda3f5bae9b711981b71a1b
                        [current] => 85687f19cf204716e9b1c608682aa22c045b6f8284a3496db07f13200952491bfea54deee7ef11115c0dedfd87443c7022ef05792892a8a984866752c8ec5726
                    )

                [core/doc/admin/_static/style.css] => Array
                    (
                        [expected] => 894b1bea3e2b6bc61824ffebc081339a6caf0b57cda7fa9b9c9a5965e2a165dc177055db176cb535ef465c927b4bc4848802fe3e1b0fb709194b3cb7d2f90f8d
                        [current] => 5d9fbe71f0eae36c5a9c50f98733cc9e7a5bc7b2b56e3937c4431cf5e54649667bbe8f5900cdcbfbaa8b1eb8d5476d42a278d210c38110411885ad818e3a963a
                    )

                [core/fonts/LICENSE.txt] => Array
                    (
                        [expected] => 4cc5a12bfe984c0a50bf7943e2d70a948d520ef423677c77629707aace3a95aa378d205de929105d644680679e70ef2449479b360ad44896b75bafed66613272
                        [current] => 98f6b79b778f7b0a15415bd750c3a8a097d650511cb4ec8115188e115c47053fe700f578895c097051c9bc3dfb6197c2b13a15de203273e1a3218884f86e90e8
                    )

                [core/vendor/jquery-migrate/jquery-migrate.js] => Array
                    (
                        [expected] => 083c7aaf7b7304b2610ed5ff851f840d5db24993814128b86f42e8e5749b76e7117f6f154a8465fb4f163c1105ec3c6a5757e9c48b95e869d101de9399780a0e
                        [current] => fc2f4d093d3c8ecbfd30f25c59f30e92bf7457664ecf8871247b1802671b05b674c047bfcd0c2c9a674b49ce0bab9cdaed2416f69797381c775019ec250cbc0d
                    )

                [core/vendor/jquery-migrate/jquery-migrate.min.js] => Array
                    (
                        [expected] => 7c31817254b71d4cac10120aa2829614311658e468036d27eb43b063b392620c4611ec3db3b3600da3e48fb82a41c5579c048fbd9022156f038b2b6cb5d946b5
                        [current] => 7b68a43a22a41404a2ff58e0da6a237492cad0fc3e56d216980802b4d5fb483895262a7e049340d6670002bdf899ba88c319239e60d0aae1ac31d98556b0ad6e
                    )

                [core/vendor/jsTimezoneDetect/jstz.js] => Array
                    (
                        [expected] => ece74dd6f5fc9587cf167dd17df51b66f70bd711f445da8d1d21bb1b0570f3c97b25d3ece110b08e2f2b294369d9b775cc169b666840a5b769ba338aa6d73d48
                        [current] => beae737d18aae6e8c5fdfb0bf3389b687ec746e6b334185710cc5b8f45b73b3c57442db541807ab440b55517ef2d138f4c40148abafcb6462481016b617e1f53
                    )

            )

    )

[files_external] => Array
    (
        [INVALID_HASH] => Array
            (
                [3rdparty/Dropbox/API.php] => Array
                    (
                        [expected] => a6866ef3ceeb26d9d4b2ccc343aeaf626c82f03e279962bc7d761a68e87e5a7916ff0bcf7a350e20889557336ed9c5dd1651cfe513fa04bb8a03cd6d8f9cc484
                        [current] => 917eed2c4f6359a4d0b8658a36404c83344b0bf72ccda614dd59f97d099b3d9ef4e86691401c64d3754c3f7e0fa163eab946a25dbc7bc65e1694ffd47a054317
                    )

            )

    )

[files_texteditor] => Array
    (
        [INVALID_HASH] => Array
            (
                [js/vendor/ace/src-noconflict/mode-diff.js] => Array
                    (
                        [expected] => 4a59b6376376b81e4e12ccc345065db62029a61035a88e19b1be3d7ec4cd9f86444121cca6d46c44a5f86e4f5b44d5109cbc77e80c07ff8dbce61f758b88e765
                        [current] => 298cba4d3b472b418aca47db6522c752a4b5530de3f6f2d83eb42eb5fe4231356bfd860a7e2f735b3e5ced759dbc6ca26fc6a18c49bd7ffa07d5a6faa78ae51d
                    )

            )

    )

)


List of invalid files after new installation
Integrity Check fials for some files
#2

Hi,

this is most likely caused by:

When using a FTP client to upload those files make sure it is using the Binary transfer mode instead of the ASCII transfer mode.
(from https://doc.owncloud.org/server/9.1/admin_manual/issues/code_signing.html#fixing-invalid-code-integrity-messages)

All releases are signed and have a correct integrity so something goes wrong with the way you're uploading the files or the way you did the upgrade (e.g. missing to overwrite all files).


#3

Interesting. I don't see a way to set that in FileZilla unless you mean SFTP.

And, is it possible to just re-upload another zip file using the binary mode without messing up everything that I set up today?

  • m

#4

Please have a look at the manual of FileZilla. There is definitely a possibility to choose that mode as i have read from that from a few users quite often. After you have found that option upload the mentioned files again and rescan the integrity (both is described in the linked documentation).


#5

Yeah, it's there. It's in the "Transfer" menu.

Cool!

I never knew about that option.

Appreciate your replies.

-- m


#6

Update.

Did manual replaces, in binary mode, of the files (style.css not found in 9.1), but it made no difference. There are still the same integrity check errors.

Sigh.

Thanks for the idea anyway. :slight_smile:

-- m


#7

Can you download the file again from your server and check it? For windows there are also methods to create a hash sum: http://superuser.com/a/898377

Is it your server? Then you could download the zip on your server and extract the files directly. Or try a different transfer client.


#8

Have you re-scanned the integrity afterwards? This won't be done automatically as described in the linked documentation above.


#9

I did rescan, but after waiting a while and re-scanning again, I'm down to four internal files that don't have the right hash.

One of these files: " core/doc/admin/_static/style.css" I didn't even see in the download zip file. In the 9.1 zip file it was "styles.css".

The other three core files are:
- core/fonts/LICENSE.txt
- core/vendor/jquery-migrate/jquery-migrate.js
- core/vendor/jquery-migrate/jquery-migrate.min.js

Thanks,


#10

I had the same problem, just needed to re-upload until it worked.
Check for size differenses.

I even think I changed back and forth between binary and the other mode in FileZilla to finally get rid of all errors.
Also restarting the webserver seemed to help.


#11

Thanks for your reply. :slight_smile:

This is a production server so I'll try a reboot this weekend.

Thanks again.

-- m