How do i link directly to the owncloud portal without using the /owncloud at the end of my fqdn

hosting
webserver_issue

#1

i am new to ucs and owncloud. just installed the esxi ova and got things working nicely and really like the platform so far. one question:
in order to get to my owncloud server i have to use https://fqdn/owncloud
if i go to https://fqdn, i wind up at my ucs server
i’d like to setup my fqnd link to go straight to my owncloud server and have another link that would take me directly to the ucs server portal.

is there a way to modify the index file through the configuration portal?

how do i make this happen?

thanks


#2

You can configure an redirect to /owncloud in the apache configuration


#3

I am far from an expert in apache. do you have some instructions or a link perhaps as to what needs to be done. I thought there was an option somewhere to redirect http to https and it does work on my server. Is this something that can be accomplished with a variable in the univention configuration registry?

i just installed my own ssl certificate on my site and noticed that some commands such as ucr set were not recognized by bash. i searched for apache redirects and found some instructions but i’m not sure if these would work for this distro as i am not an expert on linux but can find my way around.

any help is greatly appreciated.

thank you


#4

okay, you got two thing here, so lets take one problem at the time.

  1. A redirect in Apache is not really a hard thing to do, there are many tutorials in the web, you already found some. I would just try and see what works.

  2. the ucr commands expect an ucr to be there, which is the case on an UCS server. If you only have a Linux system, or ownCloud in Docker, there is no ucr.
    Where are you trying to execute the ucr set variables? on the UCS host system or in the ownCloud docker container?


#5

thank you, i’ll look for apache redirects and see what i can find.

not too worried about the 2nd part since i just brought it up as an example of my experience with trying to install my own certificate and running into this where ucr set was not recognized. i’m not sure about where i’m trying to execute the ucr set. i don’t know the difference between ucs server and owncloud in docker. i downloaded the Univention-App-owncloud-ESX.ova appliance and deployed it. after the install it seems as though i have an appliance that is serving the ucs management tools at https://ucs-server/univention/portal and the owncloud portal at https://ucs-server/owncloud. my guess is i only have owncloud in docker. i’ll have to read about docker a bit as i don’t know what it is as i’m writing this.

i used a putty session to log into the server and that is where i tried to execute the ucr set. incidentally, that is also where i executed openssl to get my private key and csr files (which worked fine except some options in openssl where not recognized)

if this environment that i’m executing commands in is somewhat limited, will apache redirects work here?

thank you for spending the time to help out. it’s my belief that good deeds don’t go unanswered

thanks again


#6

Are you connecting as root or as Administrator?

This is my output if I try to enter ucr set:

root@ucs-123:~# ucr set
E: too few arguments for command [set]

#8

that was the problem, i was logging in as administrator (windows brain washing). i logged in under root and now ucr set is recognized
so do i have a ucs linux server or owncloud in docker?

thanks again for helping a linux noobie limp along.


#9

No Problem.

You have both.

You have a host, Univention Corporate Server - A Debian System - Debian is a Linux distribution, like Ubuntu.

On that you have docker - a virtualization software, like Virtual Box, but without the graphic Interface

And ownCloud runs as a Docker container on that Software on your host.

In summery

{Appliance
[UCS Debian
(owncloud docker)
]
}


#10

got it. that all makes sense now.

i’ll try the redirect and will post my results. maybe the thread will help another noob out in the future.

have a good one


#11

Good day to you too, and good luck :slight_smile: