How to config owncloud to use a proxy for the marketplace?

marketplace

#1

Hi,

I have copy OC to a new Server and try to upgrade OC with
sudo -u www-data php occ upgrade
But I get an error.

‘’
Repair warning: No marketplace connection: cURL error 7: Failed to connect to marketplace.owncloud.com port 443: Connection timed out
Repair warning: You have incompatible or missing apps enabled that could not be found or updated via the marketplace.
Repair warning: Please install or update the following apps manually or disable them with:
occ app:disable activity
occ app:disable contacts
occ app:disable documents
occ app:disable files_pdfviewer
occ app:disable files_texteditor
occ app:disable gallery
occ app:disable templateeditor
Repair warning: For manually updating, see https://doc.owncloud.org/server/10.0/go.php?to=admin-marketplace-apps
OC\RepairException: Upgrade is not possible
Update failed
‘’
That’s normal, because the server can only access to the Internet over a proxy.

But, how to config OC to use this proxy?


#2

RTFM, or the config.example.php

‘proxy’ => ‘proxyhost:port’