How to enable bcmath for ntlm authentication with Exchange 2010 server?


#1

Steps to reproduce

  1. Attempted to setup email server configuration.
  2. Select Authentication Metod NT Lan Manager
  3. Send test email.

Expected behaviour

Test email should be sent to admin account.

Actual behaviour

We get "The BCMath functions must be enabled to use the NTLM authenticator" message.

Server configuration

Linux ucs-4289 4.9.0-ucs104-amd64 #1 SMP Debian 4.9.30-2A~4.2.0.201706

Web server: Apache 2

Database:

PHP version:5.6.30-0+deb8u1

ownCloud version: 10.0.1

Updated from an older ownCloud or fresh install: fresh

Where did you install ownCloud from: VMware Image from https://owncloud.org/download/

Signing status (ownCloud 9.0 and above):

No errors were found

The content of config/config.php:

**List of activated apps:**

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

**Are you using external storage, if yes which one:** no

**Are you using encryption:** no

**Are you using an external user-backend, if yes which one:** ActiveDirectory

### Client configuration
**Browser:** MS Edge 41.16299.15.0

**Operating system: Windows 10

### Logs

#### Web server error log

Insert your webserver log here

#### ownCloud log (data/owncloud.log)

Insert your ownCloud log here

#### Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log
c) ...
`

We have OwnCloud 10.0.1 installed with UMC. I am stuck with email connection with our MS Exchange 2010 server. Our server supports AUTH GSSAPI NTLM and we are getting "The BCMath functions must be enabled to use the NTLM authenticator" message with auth metod NT Lan Manager enabled.
Is there any way or we need to find other solution?