How to get rid of "Transactional file locking should be configured ..."

debian stretch
owncloud 10.3.1
php-apcu 5.1.17+4.0.11-2+ub
config.php contains
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘filelocking.enabeled’ => true,
apache2 restarted

Recommendation
" Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking. See the documentation :arrow_upper_right: for more information."
still appears, when opening Settings/Admin/General.

What else to get rid of that recommendation?

You have to install redis and then follow the instructions that are relevant for you.

apt-get install redis-server php5-redis

Then paste this in your config.php

'memcache.local' => '\OC\Memcache\APCu',
'memcache.locking' => '\OC\Memcache\Redis',
'redis' => [
    'host' => 'localhost',
    'port' => 6379,
],

I need to update the docs, the link should not be so hidden at the bottom of the page.

2 Likes

php-redis 5.0.2+4.3.0-2+ubuntu18.04.1+deb.sury.org+1
in config.php:
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ => [
‘host’ => ‘localhost’,
‘port’ => 6379,
],

service apache2 restart

now the recommendation message is gone when Settings/Admin/General. — thank you dmitry.

Note: I tried that with OC 10.0.10.4.
OC did not work. So I had to remove the redis lines from config.php.
Now I tried it with 10.3.1 and it works.

2 Likes