How to htaccess disable directory view after directory move and rewrite no index.php

help

#1

Steps to reproduce
1. Download 9.1.2 OVA
2. Run the OVA
3. Move /var/www/owncloud/ to /var/www/html/
4. In web browser, navigate to http://example/apps/ (yes im aware index.php is missing, I tried to remove it but couldn't figure it out. I would also like help with this.)

Expected behaviour
Tell us what should happen
Nothing should show up or redirect to files app

Actual behaviour
Tell us what happens instead

Server configuration
Operating system: Ubuntu_14.04
Web server: ?
Database: ?
PHP version: ?
ownCloud version (see ownCloud admin page): 9.1.2 OVA
Updated from an older ownCloud or fresh install: fresh
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see [] for more info

N/A

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.
No errors have been found.

I can disclose server url if needed to troubleshoot, though I would rather not have to.


#2

I also want help removing the index.php from http://example.com/index.php from my url. idk how to enable the mods needed to rewrite the url. im a ubuntu newbie coming from windows.


#3

Hi,

please never ever move stuff around if you don't have the knowledge about the implications. The OVA is using packages from the official repositories which means your files needs to stay in /var/www/owncloud.

How to make your installation available in http://example.com instead of http://example.com/owncloud is thoroughly explained in the documentation:

https://doc.owncloud.org/server/latest/admin_manual/installation/changing_the_web_route.html


#4

Thank you very much for helping. I was looking thru the documentation but I was not able to find what I needed. That is one mystery down. Do you by any chance know how to enable the 2 apache mods I need to remove the index.php from the url? That's the only thing left to do.


#5

Hi,

as this is nothing ownCloud specific you can have a look at the Apache manual as advised. Answered questions like:

might also help.


#6

Thanks again. I'll take a look at it. I ended up downloading the vmx version instead, as I have vmware player. I'm using a fresh copy, same version of the server. I was able to change the web route thanks to the guide you linked me to. I've run into a new issue. I'm trying to open a file at the root of my owncloud called New Document.odt. I click on it and I get this:

In chrome, I can press f12 and see the console for chrome. it says this:
GET http://example.com/index.php/core/preview.png?file=%2FNew+Document.odt&c=ea5045368e2adc11372a15805af7719f&x=32&y=32&forceIcon=0 Failed to load resource: the server responded with a status of 404 (Not Found)

Please note I am using an ad blocker but it is not blocking it. I tested this by checking the same console log and by disabling the extension. Any Ideas?


#7

So we can assume this as solved so closing here. Please create new threads for new issues for the reasons explained here:


Re: How to htaccess disable directory view after directory move and rewrite no index.php
#8