How to increase maximum upload size?

help

#1

Hi. I'm using OwnCloud 8.2.7 on a shared server. I'm trying to increase the maximum upload size from 8 MB to 20 MB in the Admin page. The new size seems to be accepted when I click Save but when I reload the page it reverts back to 8 MB, and bigger file uploads get rejected.

My server PHP 5.6 configuration shows "upload_max_filesize = 32M", my OwnCloud .htaccess shows "php_value upload_max_filesize 20M", my OwnCloud .user.ini shows "upload_max_filesize=20M", and I have loads of file space.

Can anybody suggest what I need to do here? Thanks for any help.


#2

Hi,

there are various other settings required depending on your environment / webserver. All needed and known information are collected here:

https://doc.owncloud.org/server/latest/admin_manual/configuration_files/big_file_upload_configuration.html


#3

Hmm, I see my PHP post_max_size is 8M, which would explain it. Thanks.