How to install Apps from github with FreeNAS Owncloud plugin jail

help

#1

Hi community,

I run a FreeNAS 9.3 Server and installed recently the Owncloud Plugin (version 9.1.0). In Owncloud I activated a few Apps, but didn't find the News App.
After some searching the web it seemed News was directly available with previous Owncloud versions. But it still is available on github. Next problem I ran in and my actual question: How do I install Apps from github?
So I found this. After using the "git clone" command and moving the News folder into the app folder and restarting the jail, I still can't find and activate News in app section.
Did I do a mistake? Is there something that needs to be done so Owncloud "knows" there is one more app?
I went back to github and the installation notes, I tried the commands provided there, but my freenas jail couldn't process them.
I'm new to this so I'm kinda stuck here, please help.


#2

Hi,

install instructions are available at your first linked repository:

https://github.com/owncloud/news#installing-from-archive

Have you tried these? Also make sure the folder you're putting into the apps folder is called "news" and not something like "news-master".


#3

and also check on the permissions of the news folder, the webserver-user must be able to read it.


#4

I tried the first method "Installing from archive". Everything went well until I need to use the command
sudo -u www-data make
Since I'm in a FreeNAS jail, there is no sudo. Also there is no folder (?) www-data. Don't know what this www-data is actually, can't find this with locate. Finally the make command alone while I'm in owncloud/apps/news/ gives me an error message:
make: no target to make.


#5

Seems you have missed:

Starting with 8.0.0, there are two different releases: news.tar.gz and Source code. The first one requires no additional steps,

at the link above. If you have downloaded the news.tar.gz no make command or other steps are needed.


#6

Right, I missed that. I downloaded the news.tar.gz file. But why can't I find the App under root Account -> Apps? Scrolled through all the Apps but no News there.
I even enabled experimental Apps. Also restarted the jail (a few times by now).

Thought maybe I miss an Dependencie.
I installed simplexml, think I have all Dependencies now. Couldn't check if I have php (but I think owncloud doesn't work without) and php-curl (I have curl-7.50.3, might be what is meant).

Also I changed permissions recursively to root-wheel (which is standard in the jail, maybe since its a freenas plugin).


#7

You probably did something wrong when installing the app, have chosen the wrong version not matching your oC version, not having restarted your webserver/php-cache to clear some caches, not looking into the "not enabled" category or similar. Just guessing games here...