How to run php script in own cloud server


#1

Hi Guys,

I have configured owncloud server and run php from mac cmd.

When I was trying to run http://localhost:8888/index.php ( contains just echo "here" ) ... it always showing server folder structure ..( redirect ).

How I will run a pure php file through browser and run it ..

Please help.


#2

I wonder how this is related to owncloud? Issues with php files are more or less an issue of your setup or webserver i guess.


#3

Hi Tom, Thanks for your reply.

I was trying to run index.php within owncloud folder. It means, like xampp, we keep all our files within htdocs and run file using browser like localhost://owncloud/index.php..

I am trying to learn how we can do it here.. I am still in learning phase ...

Still, I don't know the exact way or we can't do it .. :frowning:


#4

I think you're mixing here something as it looks to me that you think owncloud is a webserver which is capable of running .php files.


#5

I got you but trying to run any .php file in the browser.
Now only folder structure is showing up.

Any idea or suggestion ...


#6

I guess your webserver is not correctly configured to process such php files. Maybe ask the support of your webserver for help?


#7

Sure ..let me find out the way!


#8

what system is your server? Mac is not supported!

You need a running webserver (apache or nginx) with php first.


#9

Thanks Tfiidd for your reply.

MAMP is running in MAC. I placed owncloud folder inside htdocs.

When I run "http://localhost:8888/owncloud/" in browser .. it is showing folder list after owncloud login page.

I tried to remove all files and folder and just kept index.php ( "echo 'For Testing'"), it showed me the folder structure rather than 'For Testing' in the browser.

Believe, I need some configuration for display in the browser.


#10

I don't think that you should run owncloud on a MAC. If you still want to do that you really should seek for some help from the support of that MAMP thing.


#11

Ok Tom .. let me try in ubuntu.


#12

You might have a look here: https://bitnami.com/stack/owncloud/installer

As far as I can see they offer you ownCloud on MAMP out of the box there/


#13

Thanks, Lavachequirit.

I followed https://docs.bitnami.com/installer/infrastructure/mamp/#how-to-create-a-custom-php-application

Fixed the issue..

I can see "Hello World" in the browser using the URL "http://localhost:8081/demo/".

I will seat later to check how I can fix the issue with owncloud own apps..
Some configuration issue I guess..

I am using Bitnami's MAMP Apps.


#15

Not sure about that .please ask in the forum ..Sorry, I am still in learning phase!!


#16