.htaccess & Invalid Hash


#1

See info below. My questions are:

1 - What is the correct file permission for the .htaccess file? After each upgrade I have to copy and past the .htaccess Rewrite Rule info at the end of the .htaccess file to get short urls. I’m wondering is this is because I have incorrect permissions set on my .htaccess file prior to upgrades?

I’m also wondering is this is why I’m getting the Invalid Hash error on my .htaccess file?

anyone have any ideas why and how to correct?

thanks!

Steps to reproduce

  1. Re-Scan files in admin settings

Expected behaviour

No file errors

Actual behaviour

Some files have not passed the integrity check. - File listed is - INVALID_HASH - .htaccess

Server configuration

Operating system: Ubuntu 18.04.1 LTS

**Web server: Apache

**Database: Mysql

**PHP version: PHP 7.2.10

**ownCloud version: 10.0.10 (stable)

**Updated from an older ownCloud or fresh install: fresh install

**Where did you install ownCloud from: packages

**Signing status (ownCloud 9.0 and above): ???

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.
Technical information
=====================
The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results
=======
- core
	- INVALID_HASH
		- .htaccess

Raw output
==========
Array
(
    [core] => Array
        (
            [INVALID_HASH] => Array
                (
                    [.htaccess] => Array
                        (
                            [expected] => 6fd2bca47deffbdf905bcd30ee3b487584823481202ecde931ee6527514be04d84e19aa3252d252347c5a7f0519fa903c1335de0ca26b111c2ea663300f4682f
                            [current] => 758824fbdf9f8edfe415b3e979499202644392db5823cf4a0ef7f781d6a2920e63cdce9f4a296c2736f4c0868b3417bd3d1067fdfcfca18445b9af5dd704d894
                        )

                )

        )

)


**The content of config/config.php:

<?php
$CONFIG = array (
  'updatechecker' => false,
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' => 
  array (
    0 => 'xxx',
    1 => 'xxx',
    2 => 'xxx',
    3 => 'xxx',
  ),
  'datadirectory' => '/var/www/owncloud/data',
  'overwrite.cli.url' => 'https://xxx.net',
  'dbtype' => 'mysql',
  'version' => '10.0.10.4',
  'dbname' => 'xxx',
  'dbhost' => 'localhost:3306',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'xxx',
  'dbpassword' => 'xxx',
  'logtimezone' => 'UTC',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_from_address' => 'owncloud',
  'mail_domain' => 'xxxcom',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'xxx',
  'mail_smtpport' => '465',
  'mail_smtpname' => 'xxx',
  'mail_smtppassword' => 'xxx',
  'files_external_allow_create_new_local' => 'true',
  'maintenance' => false,
  'loglevel' => 3,
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'filelocking.enabled' => 'true',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0,
    'dbindex' => 0,
  ),
  'theme' => '',
);


List of activated apps:
Enabled:

  • activity: 2.4.1
  • brute_force_protection: 1.0.1
  • calendar: 1.6.1
  • comments: 0.3.0
  • configreport: 0.1.1
  • dav: 0.4.0
  • federatedfilesharing: 0.3.1
  • federation: 0.1.0
  • files: 1.5.1
  • files_clipboard: 0.7.1
  • files_external: 0.7.1
  • files_external_dropbox: 1.1.0
  • files_pdfviewer: 0.10.0
  • files_sharing: 0.11.0
  • files_texteditor: 2.3.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • files_videoplayer: 0.9.8
  • firstrunwizard: 1.1
  • gallery: 16.1.1
  • impersonate: 0.4.0
  • market: 0.2.5
  • notes: 2.0.4
  • notifications: 0.3.5
  • provisioning_api: 0.5.0
  • qownnotesapi: 17.7.0
  • systemtags: 0.3.0
  • tasks: 0.9.6
  • updatenotification: 0.2.1
  • wallpaper: 0.1-

**Are you using external storage, if yes which one: Yes. Local and dropbox

Are you using encryption: no

Client configuration

Browser:


#2

Hey,

maybe the following documentation helps you on how to correctly configure your config.php to enable short URLs?

https://doc.owncloud.org/server/administration_manual/configuration/server/index_php_less_urls.html


#3

Thank you. that is helpful and I hadn’t seen that particular documentation before. I was able to correct the problem by recopying the .htaccess file to my directory from a new download and then making my alterations at the bottom of the new file.


#4

This post was flagged by the community and is temporarily hidden.