.htaccess seems to work but getting an error

I am getting this error “Your data directory and your files are probably accessible from the Internet. The .htaccess file is not working. We strongly suggest that you configure your web server in a way that the data directory is no longer accessible or you move the data directory outside the web server document root.”

the .htaccess itself seems to be used, if i break it intentionally i get the internal server error message.
I have also enabled mod_rewrite.

I also followed the steps on How to fix "the .htaccess file does not work" message

However this error appears if i add

deny from all
IndexIgnore *


Used the script from the installation docs to set correct permissions.

Server configuration

Operating system: armbian on a odroid

Web server: Apache

Database: mariadb 10.3

PHP version: php7.3

ownCloud version: (see ownCloud admin page)

Are you using external storage, if yes which one: local

Are you using encryption: no

Are you using an external user-backend, if yes which one: no

Did you also do this step from the FAQ instructions:

Yes, i have done the vhost part as well as the apacha2.conf one.
I believe these settings just ensure that the .htaccess is actually used?
If i break the file intentionally for example by adding .Test on top I will get this

Which means these configs are correct, or am i misunderstanding what the AllowOverride settings do?

After upgrading owncloud to 10.4 today it fixed itself.