HTTP/2 Owncloud 10.4.1 with 20.04 LTS and suhosin for php7.3?

Hello All

Question, i have tried to use HTTP/2 on Owncloud directories. No luck to get it working.

Does someone have a working how to? Tried different things. Some advice would be great. :slight_smile:

By the way, does someone get suhosin working with owncloud 10.4.1 and the latest version of php7.3 ?

It seems, that the project is also supporting php7.4. But when i use the command make debian i get errors like php7.1-dev php7.2-dev. It seem’s the i am making something wrong or i have a false file. Version is 0.5 of suhosin projects website.

Thanks and nice sunday!

Best, fabius

1 Like

Hello,

I don’t understand what you mean, could you explain a bit further, maybe put some logs, screenshots, anything that might explain the problem.

I’m not sure it’s related to ownCloud since I don’t think suhosin is a module required. I can’t tell about it, but it seems the project is kinda dead, the latest release is from 2015.

How about filling the form to provide us some better information about your installation ?
Cheers.

2 Likes

HTTP/2 is a function of your webserver. I have it enabled on my ownCloud instance. The required settings are configured entirely outside of ownCloud. If you are using Apache 2.4, you might want to check out their HTTP/2 guide.

As far as Suhosin, I have never used it, but it appears to be a security hardening oriented source patch for PHP5 which isn’t going to work with the current supported PHP7 versions that are required by ownCloud.

2 Likes