I cannot login Owncloud 9.0.4

9.0.x
help

#1

Steps to reproduce
1. I type in the browser the URL for my Owncloud server
2. I type the User (Admin)
3. I type the password

Expected behaviour
It should open and displays the folders and stuffs storaged in the Owncloud account

Actual behaviour
Nothing happens. It just reloads the same page with the fields to be filled empty again. No error message or whatsoever.

Server configuration
Operating system: Debian Jessie
Web server: Apache
Database: MySQL
PHP version: PHP Version 5.6.24-0
ownCloud version (see ownCloud admin page): Owncloud 9.0.4
Updated from an older ownCloud or fresh install: Fresh install
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808): I get access denied to this

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): Storage in a pendrive

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

#2

Looks like a permission problem. If you install owncloud to /var/www/owncloud:

find /var/www/owncloud/ -type f -print0 | xargs -0 chmod 0640
find /var/www/owncloud/ -type d -print0 | xargs -0 chmod 0750
chown -R www-data.www-data /var/www/owncloud/

This sets the owner of all files in /var/www/owncloud to www-data and sets the permission to 640 for files and 750 for folders (for more on this: https://en.wikipedia.org/wiki/Chmod).


#3

Thank you for your quick response, but that didn't solve it. I still have the same problem after trying that. I don't understand why there woulb be a permission problem so in a sudden, it was working fine after configuring it on Saturday.


#4

Hard disk full or your pendrive is not mounted any more?
check with: df -h


#5

It still have plenty of space and, according to df -h, the pendrive is still mounted :disappointed:


#6

Is it possible that it has something to have with the https access?


#7

It is unusual that you have no logs. Can you explain why you don't have access to the logfiles?

As root user you should be able to access owncloud.log? Normally it shows you why the login fails, it's likely to be a database error. But that should show up in your logfiles.


#8

Did you change anything? Did you run an upgrade? Wouldn't be my first suspect but if you changed something, it could be....


#9

I don't know, if I try to open it from the browser I get a message saying: acces denied:

But if I open it in the shell as root the file is empty.


#10

Yes, it's not possible via browser directly (an attacker could gather interesting information from your logfile). Only the admin can see it on the admin page.

Now, you have directly retrieve the logfiles from your folder (login via ssh/ftp/...)


#11

I found the log file in the pendrive and opened it in the shell, I thought it was in var/www... This is what I see:

{"reqId":"cfJY9yFF62DS7ufK+utv","remoteAddr":"79.145.226.69","app":"mysql.setup","message":"Specific user creation failed: An exception occurred while executing 'SELECT user FR$
{"reqId":"cfJY9yFF62DS7ufK+utv","remoteAddr":"79.145.226.69","app":"mysql.setup","message":"Database creation failed: An exception occurred while executing 'GRANT ALL PRIVILEGE$
{"reqId":"TEEGZfEwNYb8mNbFtcGH","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 182 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"35RMl345Yt+V+S0mCFG+","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 184 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"Fr0BWEhc5G6sD\/Op2ZdG","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 180 bytes exceeds the limit of 20 bytes at Unknown#0","leve$
{"reqId":"0F02SpX5+cPg8P\/dGY2z","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 180 bytes exceeds the limit of 20 bytes at Unknown#0","leve$
{"reqId":"0W2DhXxZOJJFOys1nFz0","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 180 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"BzT2gaSGlgAHXCywGodm","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 183 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"mOMuP82uASIPmwz2WVZn","remoteAddr":"79.145.226.69","app":"core","message":"Login failed: 'Olatz' (Remote IP: '79.145.226.69')","level":2,"time":"2016-07-29T19:29:34+0$
{"reqId":"2HZHR8xxUHNz0ii+qVOK","remoteAddr":"85.155.146.123","app":"PHP","message":"Undefined index: action at \/var\/www\/html\/owncloud\/core\/ajax\/appconfig.php#28","level$
{"reqId":"2HZHR8xxUHNz0ii+qVOK","remoteAddr":"85.155.146.123","app":"PHP","message":"Undefined variable: app at \/var\/www\/html\/owncloud\/core\/ajax\/appconfig.php#38","level$
{"reqId":"2HZHR8xxUHNz0ii+qVOK","remoteAddr":"85.155.146.123","app":"PHP","message":"Unknown: POST Content-Length of 57 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"slOM7\/1OMWkhH8z5Mu7m","remoteAddr":"85.155.146.123","app":"PHP","message":"Undefined index: appid at \/var\/www\/html\/owncloud\/settings\/ajax\/enableapp.php#33","l$
{"reqId":"slOM7\/1OMWkhH8z5Mu7m","remoteAddr":"85.155.146.123","app":"core","message":"App \"\" cannot be installed because appinfo file cannot be read.","level":3,"time":"2016$
{"reqId":"slOM7\/1OMWkhH8z5Mu7m","remoteAddr":"85.155.146.123","app":"PHP","message":"Unknown: POST Content-Length of 21 bytes exceeds the limit of 20 bytes at Unknown#0","leve$
{"reqId":"1x159YQMRNRGWe58ZWKn","remoteAddr":"192.168.1.46","app":"core","message":"Trusted domain error. \"192.168.1.46\" tried to access using \"192.168.1.38\" as host.","lev$
{"reqId":"9amb6iWaKPzRTUQ74vf5","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 185 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"fwM2iV+TEE\/siiRab\/zQ","remoteAddr":"192.168.1.46","app":"core","message":"Trusted domain error. \"192.168.1.46\" tried to access using \"192.168.1.38\" as host.","l$
{"reqId":"jVd9SIe6AcsdzvYK0ycj","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 185 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"IVg1QVpczXZwtIl3ZqNp","remoteAddr":"192.168.1.46","app":"core","message":"Trusted domain error. \"192.168.1.46\" tried to access using \"192.168.1.38\" as host.","lev$
{"reqId":"iIC45zhukhe9AbjSYxeO","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 191 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"hA6HLiZdr5hCFbxFQQs+","remoteAddr":"192.168.1.46","app":"core","message":"Trusted domain error. \"192.168.1.46\" tried to access using \"192.168.1.38\" as host.","lev$
{"reqId":"zyAt6qbU5pT2lx8wigcB","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 190 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"xepeJOGK4FQjCG2Cud68","remoteAddr":"192.168.1.46","app":"core","message":"Trusted domain error. \"192.168.1.46\" tried to access using \"192.168.1.38\" as host.","lev$
{"reqId":"vVPTtabcw6EtXIPcquw6","remoteAddr":"79.145.226.69","app":"core","message":"Login failed: 'Olatz' (Remote IP: '79.145.226.69')","level":2,"time":"2016-08-01T10:27:33+0$
{"reqId":"\/PPavpW8tQcKRI6CEZja","remoteAddr":"79.145.226.69","app":"core","message":"Login failed: 'Olatz' (Remote IP: '79.145.226.69')","level":2,"time":"2016-08-01T10:27:48+$
{"reqId":"YVc4wp+DSxN9HFRio+NH","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 177 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"mWDsNiBYW2WnzvQuC8ZM","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 176 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"H5iL\/tOMG0MM5kaVsiwS","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 174 bytes exceeds the limit of 20 bytes at Unknown#0","leve$
{"reqId":"Z\/e8c4xF05IR58t1ns3N","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 175 bytes exceeds the limit of 20 bytes at Unknown#0","leve$
{"reqId":"9PLM6qDQNchUFOicVLKf","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 181 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"h8ZDkFdQSOTmSYQXZbV0","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 254 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"PIqRcI9dCmpnS7\/ajPGP","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 182 bytes exceeds the limit of 20 bytes at Unknown#0","leve$
{"reqId":"q2Xh1ev7MILarDyD6bSg","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 182 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"GKt6WaIVMUmY4fFkYR3Y","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 185 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"nsiqssyly4A7qBPtj5OJ","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 185 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"I82AtHaoM+DPBotKDPm1","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 185 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"KTyFsQFFMrvers8VAnjh","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 185 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"iV9LXebLXzJ36jqjM3TB","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 189 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"iersd8SWT96mQOihqagK","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 189 bytes exceeds the limit of 20 bytes at Unknown#0","level$
{"reqId":"6aI3l9Ve4RdUs2vmISru","remoteAddr":"79.145.226.69","app":"PHP","message":"Unknown: POST Content-Length of 185 bytes exceeds the limit of 20 bytes at Unknown#0","level$


#12

I saw the error there and fixed it :smiley: Now I can login.
Thank you very much for your help.
Anyway,do you know why Windows doesn't let me use the certificate?


#13

What did you fix, the php upload limit?

From your screenshot, I suspect that you don't have an official certificate. Perhaps it is possible to get letsencrypt-certificates for ddns-domains.


#14

POST Content-Length of 189 bytes exceeds the limit of 20 bytes

You have broken your setup by configuring a wrong / too low post_max_size within your .htaccess or php.ini so closing here. Please create a new thread for your new question for the reasons described here:


#15