I can't change the default language in oc server9.1.1

reported_bug
9.1.x
help

#1

I installed oc9.1.1 in centos7.0 with lnmp1.3(Linux+nginx+mysql+php).when i logged and find just only english in language selection.

Please help us to change something to set other language,thanks a lot.


#2

You're most likely missing the language files shipped with a default oC installation.

Try to redo the installation with one of the resources listed here: https://owncloud.org/install/#edition and make sure that you're uploading all files and folders.

If you're using an own theme disable that as well


#3

I change the 8.2.8version ,but the same as 9.1.1,the files maybe not missed when i download the tar.bz2.
I get the www user with owncloud, theme is default.
I install the 9.1.1 in CentOS7,and the CentOS support Chinese,but whether 8.2.8 or 9.1.1,the selection in personal's language just English in it,not others.


#4

Try it with the languagesCodes.php and the config.php:
https://doc.owncloud.org/server/9.1/admin_manual/configuration_server/language_configuration.html


#5

I tried to have no effect, after entering the language settings or only English options.


#6

I installed the yum install owncloud way once, still the selection in personal's language just English in it.
Maybe my OS something wrong?
How am i to do?


#7

Do you get this effect with every browser? Try it with another one, please.
If "yes", create an issue under https://github.com/owncloud/core/issues .
CentOS 7 is listed as a supported operating systemon https://doc.owncloud.org/server/9.1/admin_manual/installation/linux_installation.html .


#8

I used the chrome48 and ie11, the phenomenon is still the same, can not choose other languages, only a English.

OK,I submitted the No26286. issue, thanks a lot.


#9

Ref:


#10

The OP had added the PHP scandir() to the disable_functions php.ini setting which caused that issue: https://github.com/owncloud/core/issues/26286#issuecomment-252060841

Another one of such cases where people messing with their config without knowing the impact on their setup...