I can't select users to share files

I updated my owncloud to the current version 10.7 and when I try to share a folder or a file I cannot select any user.

Ubuntu server 20.04
Owncloud 10.7
Mysql 8.0
PHP 7.4.3

I have tried writing the full name of the user, the id, the email and with none of them I have managed to make owncloud look for it to be able to select it.

Previously if I could write a part of the user and the search engine would show me the suggestions, example: before I wrote “ja” and the search engine found 2 user matches: jairo and jaime. Now I type “ha” and no match appears and the users are still active, they have not been deleted.

I’ve been looking at forums, but I can’t find that someone has happened to him.

I appreciate all the help you can give me.

Hi Freddy,

which browser are you using? Can you try Chrome if you are using other browsers?

Hi dmitry,
I am testing with Google Chrome Version 90.0.4430.93 (Official Build) (64 bits) and I also tried with Mozilla Firefox 89.0 (64 bits) in both the same thing happens to me.

OS Ubuntu 18.04.5 LTS

yes I test this on google chrome same happened to me :roll_eyes:

You need to check the admin sharing settings, there are a multitude of settings which could affect the sharing behavior so that you can’t find any (or certain) users.
Have a look at the screenshot below for a few that are obvious to me (I don’t think this list is conclusive):

Thank you eneubauer for the comment.

I verified and all permissions that are evidenced in the image that you attach are the same that I have configured on the server

If someone else has this problem please tell us what the solution is, thank you

Does the debug console shows anything, eg the requests generated by your keystrokes?
Something like:

XHR GET https://*******/ocs/v1.php/apps/files_sharing/api/v1/sharees?format=json&search=te&perPage=200&itemType=file
[HTTP/2 200 OK 300ms]

This is what is displayed on the console when you press the keys:

“GET /*******/ocs/v2.php/apps/notifications/api/v1/notifications?format=json HTTP/1.1” 200 872 “-” “Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.93 Safari/537.36”