I can't upload a file

I have a very high probability of not being able to upload files to my area (Not sharing). They are not affected by filename, filename length, file size, file type, or language used.
For example, a document is scanned with a copier and processed into PDF. I do it twice and make two PDF files. When I try to upload them, one succeeds and one fails.

I will be warned as below.
“You don’t have permission to upload or create files here.”

This happens whether I use a web browser or a WebDAV connection (on Windows).
How can I increase the success rate of file uploads?

Best Regards,


ownCloud 10.6, PHP 7.3.14, CentOS, LiteSpeed

I have reinstalled ownCloud and it behaves exactly the same.
Files that can be uploaded and files that cannot be uploaded. There is absolutely no commonality between them. I can’t even upload a text file.

I checked the file permissions on the server, and there is nothing wrong with that.
What could be causing this?

SELinux? Run the following and show us the output:

sestatus
ls -alZ /path/to/your/owncloud-folder{,/data}

I don’t use SELinux.

PDFs created with Adobe illustrator cannot be uploaded.
Is this a hint to solve it?
Is there a way for ownCloud to unconditionally accept files of any type?

The file is crappy:

There was a problem opening the file /tmp/mozilla_abu0/testfile.pdf.

The file you opened has some invalid characters. If you continue editing this file you could corrupt this document.

Anyway, I can upload the file w/o any problem.

1 Like

Increase log level, provide output of owncloud.log, usually found in data folder of owncloud installation, but can also be found in the webinterface if logged in as admin.

Thanks for the info.

The only logs output when I upload are the following two.

{"reqId":"TcLiZuRW2o0SEqglhqAD","level":0,"time":"2021-02-18T01:17:47+00:00","remoteAddr":"XXXXXXX","user":"XXXXXXX","app":"OC\\User\\Session::validateToken","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"token c97994291f0c6e0fabfe2b4cfd8f884332c7200dfedf32f42f3b1cecf24b1f5304229203405172138370a72449a9bb3dcba61b4cd76e5d5efcb8cb4e3d445fbf with token id 2 found, validating"}
{"reqId":"TcLiZuRW2o0SEqglhqAD","level":0,"time":"2021-02-18T01:17:47+00:00","remoteAddr":"XXXXXXX","user":"XXXXXXX","app":"OC\\User\\Session::validateToken","method":"GET","url":"\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"token c97994291f0c6e0fabfe2b4cfd8f884332c7200dfedf32f42f3b1cecf24b1f5304229203405172138370a72449a9bb3dcba61b4cd76e5d5efcb8cb4e3d445fbf with token id 2 found, validating"}

This doesn’t make any sense to me.

Loglevel is at 0, if there was a fault in ownCloud server this should log it.

So, perhaps you have a reverse proxy with some packet inspection, that rejects it? However I don’t understand how you would still receive an ownCloud error message in that case and not an error message from your loadbalancer.

Finally you neglected to fill out the post template for server topics, which asks standard questions about your environment and that could help in resolving your case.

Perhaps you have antivirus enabled and that is blocking a broken pdf?