Ignore list rule doesn't exist but causes file to be ignored

Expected behaviour

Files should be synchronised

Actual behaviour

Files aren’t synchronised

but I can’t see which rule on the Ignore List is stopping the sync.

Ignore list

*~
~$*
.~lock.*
~*.tmp
]*.~*
]Icon\r*
].DS_Store
].ds_store
._*
]Thumbs.db
System Volume Information

.*.sw?
.*.*sw?

].TemporaryItems
].Trashes
].DocumentRevisions-V100
].Trash-*
.fseventd
.apdisk

.directory

*.part
*.filepart
*.crdownload

*.kate-swp
*.gnucash.tmp-*

.synkron.*
.sync.ffs_db
.symform
.symform-store
.fuse_hidden*
*.unison
.nfs*
==========================================

Steps to reproduce

  1. Create file with filename ‘fred.bat’
  2. Click ‘Force sync now’
  3. See that ‘fred.bat’ has not been uploaded because it is on the Ignore List
  4. Open Ignore List
  5. Scratch head while trying to see which rule causes ‘fred.bat’ to be ignored
  6. Prepare excuse that, as a newbie, I can’t read the documentation…

Server configuration

Operating system:

Web server:

Database:

PHP version:

ownCloud version:10.5.0 (stable)

Storage backend (external storage):

Client configuration

Client version: 2.6.3 (build 13551)

Operating system: Win7 and Win10

OS language:

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:

Logs

Please use Gist (https://gist.github.com/) or a similar code paster for longer
logs.

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    (On Windows using cmd.exe, you might need to first cd into the ownCloud directory)
    (See also http://doc.owncloud.org/desktop/2.2/troubleshooting.html#client-logfile )

  2. Web server error log:

  3. Server logfile: ownCloud log (data/owncloud.log):

I can’t reproduce. fred.bat uploads fine. Anything blocked on the server? Does upload in web UI works?

1 Like

Thank you for your prompt response.
No. I cannot drag fred.bat into the webUI.
I get the following:
image
but I can drag fred.txt (and any other filetype) with no problem

1 Like

Check the server log for a more specific reason.

Thank you for responding.
I have read the section headed “ownCloud server log files” here
https://doc.owncloud.org/desktop/2.5/troubleshooting.html
but, as it says in blue text, there isn’t enough information to help me.

I have logged in as Admin and cannot find how to enable the logfile.
Similarly, I cannot find the logfile using FileManager on the cPanel host.

1 Like

The file (owncloud.log) should be inside the ownCloud data folder, alternatively you should be able to download the logfile from the ownCloud admin general settings page. There you might have to scroll down a little.

Before downloading it I would also recommend to increase the loglevel to 0 and reproduce the error again to make sure the logging is as detailed as possible.

EDIT: While you’re on there please also provide a configreport.

Thanks again and my apologies for my delay in replying.
Short answer: the problem wasn’t with Owncloud

After sending my previous message I discovered other, server-related problems.
It transpired that the company hosting my server had implemented a number of rules which prevented files with names such as .bat .htaccess etc from being uploaded to my Owncloud instance.
It got worse…my repeated attempts to sync Owncloud resulted in my home IP address being blocked meaning the delivery of email also stopped.

Thanks for your help.

1 Like

I had a hunch that that might be the case, but was too unsure about it and wanted to rule out other things first, before I sent you on that goose chase :wink:

Glad it’s resolved.

EDIT: I moved this thread from the Desktop to the Server topic, as it turned out that was the problem…