Impossible login : Internal Server Error

I installed the OwnCloud Appliance on a VMWare VM, and setup all was working fine. After a router reboot the ip adress changed, and from this moment, it’s impossible for me to connect to the Admin account, i get a Internal Server Error.
I can’t generate a config report, and I down’t know how to use OCC, I don’t find the right folder where he is.
At least I would like to have back my files and folders that where on the OnwCloud drive, I don’t have any backup…
Thank you !

Make sure, for the future, that the appliance is either using a static IP, or you make a reservation for the MAC address in your DHCP server.

Can you have a look in the owncloud.log file, for a more specific error message?

Please carefully read the appliance documentation

In there you’ll also find how to create backups:

Thinking about the case a little more, perhaps the easiest (and fastest) way to resolve the issue, is to create a reservation on your DHCP server for the appliance’s MAC address on the IP before the reboot and then reboot the server. That should reapply the old IP address and hopefully resolve the issue.


Thank you for the answer !
I tried just now to give a static IP to the server (by giving the old IP Adress to the univention settings, disabling DHCP) and it still doing the same error.
The owncloud log file you speak about doesn’t seem to exist, and i can’t generate it, occ still can’t be found. For the backup, I don’t have any, too.
So I’m still stuck, if you have any other advice ?

Sorry, but it is really hard to guess in which exact state you are in, and then it is even harder to formulate a way to your desired state (a working ownCloud).

The appliance docs should tell you how to run occ (you need to run some univention command first).
The backup docs, should also point you to the folder where the docker data volume should be.

As long as the docs are up to date, that should be pretty straight forward.
If all of that doesn’t help, I’d run a find on the root file systems on a unique filename that is stored in ownCloud.

But I haven’t used the appliance in a long time, perhaps @dmitry knows more?

1 Like

I changed some settings in univention settings, changed some other IP adresses for the good one (but the OwnCloud app was already on the good one), OwnCloud just worked fine again.
Thank you for your time and the answers. BTW I didn’t achieved to find the files even with a search


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.