Impossible to upload large file after upgrade 10.0 to 10.2.1

Dear Everybody,

After upgrading my owncloud server from 10.0 to 10.2.1, i can’t upload files bigger than 10Mo.
I check php.ini settings and rights on folders, it’s all good.

Has anyone experienced this problem ?
Can someone help me please :slight_smile: ?

Best Regards,

Hello @JF11,

could you fill in the template ? Also, do you have any logs ? How do you upload, through the web interface, through the client (which OS, which version) or via simple DAV ?
You might have a look at that.


Hello cs35,

I do not have any logs about this error.
I’m using a web browser to upload files (i tried a few Chrome, Firefow or IE)
Just that on the top of the page there is an error message "Could not create file “” ".

I’ll keep looking at the documentation.


Alrighty, could you open your web browser console (F12) in the network tab, and while uploading check what’s going on ? A file under 10MB uploads well ? Could be a problem with the chunking.


I think you’re right.

It seems that the file is chunking onto 10Mo files, the first one is good but not the seocnd one …
404 error un the second file.

For information my file size is 11.88Mo

Then follow the link about large files, there might be something wrong in your configuration, but it’s weird to me it should work already. The large files configuration is required when you use DAV through cURL, at least it’s what some tests had me thinking.

1 Like

I mean the PROPFIND return 404 error

That’s weird, do you have some HTTP method limitation in your web server ? For example.

1 Like

It seems that i have no restriction on my web server
it’s an apache, as simple as it can be

Could you check your apache/PHP logs, and also turn on the ownCloud logs with high verbosity ?


So I guess you checked the obvious first:

  1. Available disk space on all involved partitions.
    a) in your data directory
    b) where chunks are written
    c) php temp directories
  2. Did you change anything else other than the ownCloud upgrade, like for example PHP version upgrade, or upgrade to the whole OS
  3. Do you have redis installed and enabled?
  4. Do you have quota enabled? Either in the filesystem or in ownCloud itself.
  5. I guess there is no reverse proxy set up?

Hi eneubauer,

  1. Yes i checked space in all of the directories you quote.
  2. Yes php, and also OS was upgraded juste before owncloud.
  3. I don’t think so
  4. Yes i have some quota for my others users but the witch i’m trying with is limitless
  5. There is a F5 reverse proxy but we’ve checked it before and we don’t think that’s the point of failure.
1 Like

Hi cs35,

So after turning on verbose logs i can’t see anything even when i do upload less than 10Mo (so when it works) …


maybe you can do a direct upload without the F5 reverse proxy to rule out any problems with that (even if you think it isn’t such a problem). I think it could be possible that ownCloud 10.2.1 or some version in between changed the way files are uploaded.

It could also make sense to revert the PHP and OS upgrade to rule out any issues originating from the upgrade of both components.

1 Like

Hi @JF11,
Are you using the WebUI or the sync client to upload the large file? Any different behavior between the two?
I guess you’re using a logged-in user, not a public file drop (which would require additional configuration)?

1 Like

That’s a lot of things that changed, that could all contribute to the error. Which version of PHP are you using now? Did you make sure all the same modules are installed and configured the same.

With version 10 it is highly recommended to use redis for file locking, which could play a role here.

Do you have multiple instances behind the proxy/load balancer? If yes, do you have some kind of sticky session? What could be happening here is that the next chunk upload gets redirected to another host. Also, do all instances have the same ownCloud instance ID, or are they all different?

1 Like