Include path wrong after upgrade

help

#1

I upgraded a few days ago to OC 9.1.4 and everything worked OK. Today when I try to access OC I get a blank page. The error log shows that some required files are not loading. The problem is the path that OC is trying to use and it contains the wrong user dir.

Here is the error:

[13-Feb-2017 12:42:11 America/New_York] PHP Warning:  require(/home/dev/public_html/oc/3rdparty/composer/../sabre/uri/lib/functions.php): failed to open stream: Permission denied in /home/tcxtax/public_html/oc/3rdparty/composer/autoload_real.php on line 61
[13-Feb-2017 12:42:11 America/New_York] PHP Fatal error:  require(): Failed opening required '/home/dev/public_html/oc/3rdparty/composer/../sabre/uri/lib/functions.php' (include_path='/home/tcxtax/public_html/oc/3rdparty/pear/console_getopt:/home/tcxtax/public_html/oc/3rdparty/pear/pear_exception:/home/tcxtax/public_html/oc/3rdparty/pear/pear-core-minimal/src:/home/tcxtax/public_html/oc/3rdparty/pear/archive_tar:/home/tcxtax/public_html/oc/3rdparty/phpseclib/phpseclib/phpseclib:/home/tcxtax/public_html/oc/lib/private:/home/tcxtax/public_html/oc/config:/home/tcxtax/public_html/oc/3rdparty:/home/tcxtax/public_html/oc/apps:.:/usr/lib/php:/usr/local/lib/php:/home/tcxtax/public_html/oc') in /home/tcxtax/public_html/oc/3rdparty/composer/autoload_real.php on line 61

It is trying to use /home/dev/ when it should be /home/tcxtax/. Where is this being set? I looked in config.php and do not see anything there.


#2

I seem to have solved this but I still don't know why it was messed up to begin with. It looked like the problem was with composer so I used putty and went to the 3rdparty folder and ran composer.phar update. This updated a bunch of packages and rewrote the autoload files. Now everything works again.