Installing owncloud manually, but, get 500 error during install

installation
9.0.x
help

#1

I am using Linux Mind Debian v2. Updated to the latest version.

I am trying to install ownCloud 9.0.4 on my computer. I downloaded the zip file and installed it under /var/www/owncloud.

I have apache2, php5, MySQL installed. I changed the directory to www-data ownership and group.

But, when I try to access it via http to install I get the following message:
Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

My apache access log says:
127.0.0.1 - - [30/Jul/2016:22:30:27 -0400] "GET /owncloud/ HTTP/1.1" 500 856 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0"

Nothing in the error log relating to this (based on what I can tell from the time).

Can anyone help on how to get this installed?

I need to do it manually as opposed to the package. Unless I can tell Debian to install 9.0.4. If so, then please let me know how. Thanks.


#2

Hi,

have a look at this FAQ: https://central.owncloud.org/t/im-getting-a-blank-page-500-internal-server-error/833

A 500/internal server error is always logged into the servers logfiles (either webserver or PHP).

Unfortunately its nearly impossible to guess whats wrong here without the matching logentries to that error. Ma


#3

Hi ho,

I have apache2, php5, MySQL installed. I changed the directory to www-data ownership and group.

Change it recursively (-r), so that all files and subdirectories are included.

Check if .htaccess-files exists in the main-directory of owncloud, and in the /data directory.
Check if they have the correct file-size.

Installing Apache2, php5 and mysql is not enough.
Make sure you have installed all required php modules, as described here:
php modules

Make sure you have configured apache correctly and enabled the rewrite-module of apache2, as described here:
apache configuration
Most important:
Options +FollowSymlinks
AllowOverride All
so that .htaccess-file are executed.

after this restart apache-server and reload owncloud-webseite.

Good luck!


#4

I did recursively change the owncloud directory.

As for the .htaccess file. it's in the main directory. The data directory doesn't exist because I'm getting this error when trying to run the installation.

Also, the php modules, I didn't find several of the debian packages for them. (Not sure how I installed ownCloud on my other computer! Same OS and don't remember having this issue). The ones I couldn't find are:
PHP module iconv
PHP module libxml
PHP module mb multibyte
PHP module posix
PHP module SimpleXML
PHP module XMLWriter
PHP module zip
PHP module zlib

Regarding the apache configuration, I did follow the link you posted. I went over it again and couldn't find anything I didn't follow.


#5

Unfortunately you still need the matching logentries to that internal server error. Without that its really only a guessing game whats wrong here.


#6

I did a manual install of 9.1 in 5 minutes. So, I personally think it had to do with 9.0.4. Because I don't recall having this much trouble with 9.0.3 either.

My original data I just retrieved by re-creating my folder and data on my other computer with ownCloud 9.0.3 already installed. I'll just have to upload everything to ownCloud 9.1. I just hope there is a way to upload the whole structure. Otherwise, from what I've read, I think the client can do it.