Installing owncloud on Debian 1&1 without root


#1

Hello,

I used owncloud server for several years on a shared server from 1&1 (I had no root access)
I installed it very quicky and it was simple from the command line shell.
It worked fine but I had to upgrade owncloud from 9.1.1 to 9.1.8.
Since the installation, 1&1 changed my offer (it was suppressed) to the one called “Web essential”.

I tried to upgrade but the servers stays in “maintenance mode”.
Maybe the change of contracts with 1&1 is the cause.
Anyway, I would like to re-install owncloud server from scratch.

I have looked for an installation that doesn’t require ‘root’ and couldn’t find
What is the simplest way to install it, using shell, with minimum user’s privileges (I cannot be root neither run ‘sudo’) ?
For information about the server, ‘uname -a’ command answers:
Linux infong-fr47 3.16.0-ui18276.29-uiabi1-infong-amd64 #1 SMP Debian 3.16.59-1~ui80+1 (2018-10-03) x86_64 GNU/Linux
Thank you.


#2

No, there has been some changes in ownCloud and many apps were moved to “3rd party apps” category outside of core. When you upgrade ownCloud all 3rd party apps have to be disabled. If you have 3rd party apps and make an upgrade your server goes in maintenance mode and tells you to disable those apps and upgrade again.

I could be wrong but I don’t know any. You need to install the db, php, apache that requires root privileges.

Then you need to download the code of ownCloud and give the apache user ownership of the ownCloud code, this is also only possible with root privileges as far as I know.


#3

@paul7 I think, it could be still possible to install ownCloud without shell access. But you need a tool for creating the database, like phpMyAdmin or similar.

But beware, without shell access, in case of trouble you’re lost.

Therefore my recommendation: Do yourself a favor, switch to a hosting that will grant you full access rights. Maybe you current hosting is simply too limited for running ownCloud.


#4

Thank you for your answers.
A friend advised me to simply unzip a package.
I downloaded https://download.owncloud.org/community/owncloud-10.0.10.zip
and unzipped it. Then I connected to this new owncloud (web), entered a name and password, and after a few seconds, it worked.
My friend told me that I will be asked for the database name, user, but not this time… Probably it was stored with the previous installation.
I have now a brand new OwnCloud v 10.0.10. Perfect!
I will carefully delete the directory with Owncloud v9 (taking care of config files that could still be used).