Instant upload stuck on iOS

Steps to reproduce

  1. Random after a few months of use

Expected behaviour

Tell us what should happen
All photos should be automatically uploaded from iPhone to owncloud InstantUploads folder

Actual behaviour

Tell us what happens instead
Photos seem to be stuck in the upload queue, nothing is uploaded, upload “wheel” is spinning.

Server configuration

**Web server: apache2

**Database: mysql

**PHP version: 7.0

**ownCloud version: 10.3.2 (stable)

**Storage backend (external storage): external hdd mounted on linux filesystem


**iOS version: 13.3

**ownCloud app version: 1.2.0 build 148

**Device model: iPhone XS


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Tell us what could be improved:


I’m not sure if this has been brought up before. Apologies if it has.
For the last 3 months I haven’t been able to get any instant uploads from the iOS app. The files seem to get enqueued, but they’re spinning and not uploading. Desktop uploads work fine, this is only a problem with instant uploads. On the server side, the files seem to be “allocated” (as if they have been created as empty placeholders with the correct name) but they are also spinning as if they are in the process of being uploaded.

Any ideas? I can send a screenshot if it would be useful.

@r3m3dy Thank you very much for reporting the issue. The debug log would help to investigate what’s going on. Here you can find more information:

You can send it to ios-app<at>

1 Like

I’ll email you the debug log now from the new app. Thanks!

Btw, last night I tried the old iOS app as well, and all uploads went through…

I am also seeing this problem. Any way to force those that seem to be stuck and restart? The only option I see at the moment is to uninstall the add and start over.

Please enable “Diagnostics” in the Setting, then swipe-left the stuck item. You’ll see an “Info button”

Then share this information with apps-<at>

This will help the team to fix the root problem.

As a workaround, you can use the “Reschedule” button on that page.

1 Like