InsufficientStorage / No storage usage information available


#1

Hi all,
One single account of 40 configured is experiencing problems uploading files.
All the syncs fails with the message “There is insufficient space available on the server for uploads”.
In the desktop client e in the web interface the are no informations about the space usage and the available space.
In the desktop client the message is “Currently there is no storage usage information available”.

SERVER CONFIGURATION :

OS : Centos 7.4.1708
Webserver : Apache 2.4.28
Php : 7.0.32
Owncloud 10.0.10
MariaDB : 10.3.2
No external storages are configured.
The datadir is an nfs mounted directory. ( 5% storage usage )

LDAP Integration ( release 0.11.0 ) is enabled.
Quotas are configured : 500 GB default. The user experiencing the issue has a quota of 1024 GB.

Owncloud desktop client version 2.5.0

php occ app:list
Enabled:

  • dav: 0.4.0
  • federatedfilesharing: 0.3.1
  • federation: 0.1.0
  • files: 1.5.1
  • files_external: 0.7.1
  • files_sharing: 0.11.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • files_videoplayer: 0.9.8
  • market: 0.2.5
  • notifications: 0.3.5
  • provisioning_api: 0.5.0
  • systemtags: 0.3.0
  • updatenotification: 0.2.1
  • user_ldap: 0.11.0
    Disabled:
  • comments
  • configreport
  • encryption
  • external
  • firstrunwizard
  • user_external

php occ ldap:show-config
±------------------------------±-------------------------------------------------------------------------------------+
| Configuration | s01 |
±------------------------------±-------------------------------------------------------------------------------------+
| hasMemberOfFilterSupport | 0 |
| hasPagedResultSupport | |
| homeFolderNamingRule | |
| lastJpegPhotoLookup | 0 |
| ldapAgentName | bind |
| ldapAgentPassword | *** |
| ldapAttributesForGroupSearch | |
| ldapAttributesForUserSearch | |
| ldapBackupHost | |
| ldapBackupPort | 389 |
| ldapBase | dc=,dc=local |
| ldapBaseGroups | dc=
,dc=local |
| ldapBaseUsers | dc=,dc=local |
| ldapCacheTTL | 600 |
| ldapConfigurationActive | 1 |
| ldapDynamicGroupMemberURL | |
| ldapEmailAttribute | mail |
| ldapExperiencedAdmin | 0 |
| ldapExpertUUIDGroupAttr | |
| ldapExpertUUIDUserAttr | objectguid |
| ldapExpertUsernameAttr | |
| ldapGroupDisplayName | cn |
| ldapGroupFilter | |
| ldapGroupFilterGroups | |
| ldapGroupFilterMode | 1 |
| ldapGroupFilterObjectclass | |
| ldapGroupMemberAssocAttr | member |
| ldapHost | 10...** |
| ldapIgnoreNamingRules | |
| ldapLoginFilter | mail=%uid |
| ldapLoginFilterAttributes | |
| ldapLoginFilterEmail | 0 |
| ldapLoginFilterMode | 1 |
| ldapLoginFilterUsername | 1 |
| ldapNestedGroups | 0 |
| ldapOverrideMainServer | |
| ldapPagingSize | 500 |
| ldapPort | 389 |
| ldapQuotaAttribute | |
| ldapQuotaDefault | |
| ldapTLS | |
| ldapUserDisplayName | cn |
| ldapUserDisplayName2 | |
| ldapUserFilter | memberOf=CN=ownCloudAccess,OU=VARI,OU=“Gruppi Applicazioni”,DC=
*****,DC=local |
| ldapUserFilterGroups | |
| ldapUserFilterMode | 1 |
| ldapUserFilterObjectclass | |
| ldapUuidGroupAttribute | auto |
| ldapUuidUserAttribute | auto |
| turnOffCertCheck | |
| useMemberOfToDetectMembership | 1 |
±------------------------------±-------------------------------------------------------------------------------------+

LOG ENTRY :

{"reqId":"9eaadb9b-dcef-4fa2-afff-957689e4b7fa",
"level":0,
"time":"2018-10-12T09:42:15+00:00",
"remoteAddr":"188.216.44.90",
"user":"B80F44ED-CB71-4E18-86A7-8C1C40687781",
"app":"webdav",
"method":"PUT",
"url":"/remote.php/dE-4E18-54RF-8C1C40687781/Documents/Private\123456qazwsc.pdf",
"message":"Exception: HTTP/1.1 507 Insufficient Storage: {"Exception":"Sabre\\DAV\\Exception\\InsufficientStorage",
"Message":"",
"Code":0,
"Trace":"#0 \/store1\/www\/owncloud\/v10.0.10\/apps\/dav\/lib\/Connector\/Sabre\/QuotaPlugin.php(133): OCA\\DAV\\Connector\\Sabre\\QuotaPlugin->checkQuota('\/Documents\/Priv...')\n
#1 [internal function]: OCA\\DAV\\Connector\\Sabre\\QuotaPlugin->handleBeforeCreateFile('files\/B80F44ED-...',
 Resource id #484,
 Object(OCA\\DAV\\Connector\\Sabre\\Directory),
 false)\
 n#2 \/store1\/www\/owncloud\/v10.0.10\/lib\/composer\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array,
 Array)\
 n#3 \/store1\/www\/owncloud\/v10.0.10\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(1093): Sabre\\Event\\EventEmitter->emit('beforeCreateFil...',
 Array)\n#4 \/store1\/www\/owncloud\/v10.0.10\/lib\/composer\/sabre\/dav\/lib\/DAV\/CorePlugin.php(525): Sabre\\DAV\\Server->createFile('files\/B80F44ED-...',
 Resource id #484, NULL)\n#5 [internal function]: Sabre\\DAV\\CorePlugin-

httpPut(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#6 \/store1\/www\/owncloud\/v10.0.10\/lib\/composer\/sabre\/event\/lib\/EventEmitterTrait
.php(105): call_user_func_array(Array, Array)\n#7 \/store1\/www\/owncloud\/v10.0.10\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(479): Sabre\\Event\\EventEmit
ter->emit('method:PUT', Array)\n#8 \/store1\/www\/owncloud\/v10.0.10\/lib\/composer\/sabre\/dav\/lib\/DAV\/Server.php(254): Sabre\\DAV\\Server->invokeMethod(Objec
t(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#9 \/store1\/www\/owncloud\/v10.0.10\/apps\/dav\/lib\/Server.php(298): Sabre\\DAV\\Server->exec()\n#10
\/store1\/www\/owncloud\/v10.0.10\/apps\/dav\/appinfo\/v2\/remote.php(31): OCA\\DAV\\Server->exec()\n#11 \/store1\/www\/owncloud\/v10.0.10\/remote.php(165)
: require_once('\/store1\/www\/own...')\n#12 {main}","File":"\/store1\/www\/owncloud\/v10.0.10\/apps\/dav\/lib\/Connector\/Sabre\/QuotaPlugin.php","Line":1
68}"}

#2

How much storage do you have on the server?


#3

Hi Dmitry,
thnk you for your response.
The server has 13 TB of storage :slight_smile:

df -h /store1/www/owncloud/datadir/
Filesystem Size Used Avail Use% Mounted on
NFS-SERVER:/owncloud 13T 542G 13T 5% /store1/www/owncloud


#4

Okay, have you tried to play around with his quota?

what are your settings for LDAP quota, default quota and personal quota?


#5

Yes, i tried changing the quota.
Changed to default ( 50 GB ), to unlimited or to 500GB. The problem always persist.
ldap quota are not configured.
Special attribute “quota” and “quota limit” in the “user authentication” section are blank.


#6

Can you do a user sync after changing the quota, or are you doing this already?

occ user:sync "OCA\User_LDAP\User_Proxy" -m remove


#7

done. But the problem still persist.

Here is the outtup from the cli

php occ user:sync “OCA\User_LDAP\User_Proxy” -m remove

Analysing known accounts …
5 [============================]

No removed users have been detected.

Inserting new and updating all known users from OCA\User_LDAP\User_Proxy …
49 [============================]