Internal Error with Redis


#1

Internal Server Error

The server encountered an internal error and was unable to complete your request.

Please contact the server administrator if this error reappears multiple times and include the technical details below in your report.

More details can be found in the [server log

Technical details

  • Remote Address: 192.168.1.109
  • Request ID: W-USsFl7sqEIaEUyh708XQAAAAU
  • Type: RedisException
  • Code: 0
  • Message: Connection refused
  • File: /var/www/html/owncloud/lib/private/RedisFactory.php
  • Line: 81

Trace

#0 /var/www/html/owncloud/lib/private/RedisFactory.php(81): Redis->connect(‘localhost’, 6379, 0) #1 /var/www/html/owncloud/lib/private/RedisFactory.php(101): OC\RedisFactory->create() #2 /var/www/html/owncloud/lib/private/Memcache/Redis.php(37): OC\RedisFactory->getInstance() #3 /var/www/html/owncloud/lib/private/Memcache/Factory.php(131): OC\Memcache\Redis->__construct(‘0ec155981b96843…’) #4 /var/www/html/owncloud/lib/private/Server.php(721): OC\Memcache\Factory->createLocking(‘lock’) #5 /var/www/html/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC{closure}(Object(OC\Server)) #6 /var/www/html/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(108): Pimple\Container->offsetGet(‘LockingProvider’) #7 /var/www/html/owncloud/lib/private/ServerContainer.php(86): OC\AppFramework\Utility\SimpleContainer->query(‘LockingProvider’) #8 /var/www/html/owncloud/lib/private/Server.php(1485): OC\ServerContainer->query(‘LockingProvider’) #9 /var/www/html/owncloud/lib/private/Files/View.php(120): OC\Server->getLockingProvider() #10 /var/www/html/owncloud/lib/private/Server.php(172): OC\Files\View->__construct() #11 /var/www/html/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC{closure}(Object(OC\Server)) #12 /var/www/html/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(108): Pimple\Container->offsetGet(‘EncryptionManag…’) #13 /var/www/html/owncloud/lib/private/ServerContainer.php(86): OC\AppFramework\Utility\SimpleContainer->query(‘EncryptionManag…’) #14 /var/www/html/owncloud/lib/private/Server.php(916): OC\ServerContainer->query(‘EncryptionManag…’) #15 /var/www/html/owncloud/lib/base.php(751): OC\Server->getEncryptionManager() #16 /var/www/html/owncloud/lib/base.php(665): OC::registerEncryptionWrapper() #17 /var/www/html/owncloud/lib/base.php(994): OC::init() #18 /var/www/html/owncloud/index.php(53): require_once(’/var/www/html/o…’) #19 {main}

anyone can please direct me what could have been wrong in here? if I remove this lines in my config

‘filelocking.enabled’ => ‘true’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ => array(
‘host’ => ‘localhost’,
‘port’ =>0,
‘timeout’ => 0.0,
),

everything is loaded except for the error message:

  • Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking. See the [documentation :arrow_upper_right: for more information.

#2

Hi,

what guide were you using ?

This is obviously wrong, you should consider reading the official ownCloud docs at doc.owncloud.com


#3

after following this one
https://doc.owncloud.org/server/10.0/admin_manual/configuration/server/caching_configuration.html

I end up following this thread.


#4

Okay but even in this post the configuration is different than yours:

the author’s config

'memcache.local' => '\OC\Memcache\APCu',
'memcache.locking' => '\\OC\\Memcache\\Redis',
'filelocking.enabled' => 'true',
'redis' => 
array (
'host' => '/var/run/redis/redis.sock',
'port' => 0,
'timeout' => 0.0,
),

your config:

‘filelocking.enabled’ => ‘true’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ => array(
‘host’ => ‘localhost’,
‘port’ =>0,
‘timeout’ => 0.0,
),


#5

ahh yes, I change that after I used the original config from the author. SInce I still end up with the same issue and that didn’t resolve my issue and yes I put it back the way it is right now. and comment it since it crashes when I uncomment it.


#6

after reading the docs. I endup with this config, but now it doesn’t load anything just saying it " This site can’t be reached too long to respond"

<?php $CONFIG = array ( 'updatechecker' => false, 'instanceid' => 'oco1d6w9ff9h', 'passwordsalt' => 'nXr0i1+N9nFYzG2PPrhdYF8yWqIpQ8', 'secret' => 'AH3JaEcsN8DavRURbdg9JGtRU+beuWmFScKEM/1mqZNRNsja', 'trusted_domains' => array ( 0 => '192.168.1.109', ), 'datadirectory' => '/var/www/html/owncloud/data', 'overwrite.cli.url' => 'http://192.168.1.109', 'dbtype' => 'sqlite3', 'version' => '10.0.10.4', 'logtimezone' => 'UTC', 'installed' => true, 'memcache.local' => '\OC\Memcache\APCu', 'filelocking.enabled' => true, 'memcache.locking' => '\OC\Memcache\Redis', 'redis' => [ 'host' => 'localhost', 'port' => 6379, 'timeout' => 0.0, ], );

#7

Hey,

could it be possible that you havn’t installed redis at all?


#8

it’s already installed, I have redis-3.2.12-2.el7.x86_64


#9

Hey,

i think it might be possible that just installing it isn’t enough. e.g. your initial post had a “Connection refused” which seems that either redis is not listening on the expected port or your system is somehow blocking ownCloud to access the configured port.


#10

I dont have firewalld, nor iptables or selinux running. I as able to solve the connection refused, I check on my logs and saw module being loaded repeatedly. but now with my configuration I am still seeing that warning for

Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking