Internal ip vs NOIP domain

Steps to reproduce

To begin with, without the line ‘overwritehost’ => ‘XXXXX.ddns.net’, can log in with the internal ip 192.162.x.x/owncloud and perform all admin tasks including upload of files and adding users. when email is sent to new user the link is incorrect and they cannot set a new password.

  1. internal ip being sent to new user meaning the link is not functional
  2. add ‘overwritehost’ => ‘XXXXX.ddns.net’, to config.php
  3. new user link is now correct and pointing to NOIP domain name

Expected behaviour

After step three the behavior is as expected

Actual behaviour

The new user gets the correct link and can set password. New user cannot upload files even if given permission. the admin can no longer access the server from inside the network as internal ip is being redirected to external domain. Would not be a problem but admin cannot access full settings and cannot upload files.

What is the value for 'overwrite.cli.url' => '', ?

I mistyped in original post with 192.162.x.x as internal ip it is as below.

‘overwrite.cli.url’ => ‘192.168.x.x’,

Was thinking, can the email template be modified to help?

I did answer my question about the email template by more searching in this forum and the answer is no.
I still have not figured out the answer to the issue of having to adjust the config.php file when I wish to upload from inside my network. Also have not figured out why a user cannot upload from outside my network using the web interface immediately getting a file timeout error.

Do you have a local server and you are using port forwarding with NOIP? I would check if this works first and then debug deeper with commands that track the packages and see what IP / Domain Names are being used.