Internal server error after reboot and ssl-replacement

Steps to reproduce

  1. Connect to l3iggs/owncloud container and wildcard included in httpd-ssl and drop the certificates into the paths.
  2. Web access via FQDN:PORT and then an “Internal Server Error” appears
  3. Just did a reboot and then installed the wildcard. After that no more access to Owncloud

Expected behaviour

SSL certificate should be displayed in the browser and OwnCloud GUI should be displayed.

Actual behaviour

The wildcard certificate is displayed when accessing via https://FQDN:PORT but an error message with the error code “Internal Server Error” appears. Seems more like the
DocumentRoot is not right (httpd-ssl.conf & owncloud.conf) but i don’t know what’s the problem here.

Server configuration

Operating system:
Ubuntu 14.04 LTS

Web server:
Apache 2.4.17

Database:
mysql 5.7.10

PHP version:
PHP 5.6.16

ownCloud version: (see ownCloud admin page)
Not sure where i can see that…can’t access to the admin gui

Updated from an older ownCloud or fresh install:
image install -

Where did you install ownCloud from:
l3iggs/owncloud image

The content of config/config.php:

<?php
$CONFIG = array (
  'instanceid' => 'deleted',
  'passwordsalt' => 'deleted',
  'secret' => 'deleted',
  'trusted_domains' =>
  array (
    0 => 'ip:port',
    1 => 'fqdn',
  ),
  'datadirectory' => '/usr/share/webapps/owncloud/data',
  'overwrite.cli.url' => 'https://ip:port',
  'dbtype' => 'mysql',
  'version' => 'deleted',
  'dbname' => 'deleted',
  'dbhost' => 'deleted',
  'dbtableprefix' => 'deleted',
  'dbuser' => 'deleted',
  'dbpassword' => 'deleted',
  'logtimezone' => 'UTC',
  'installed' => true,
  'loglevel' => 0,
  'apps_paths' =>
  array (
    0 =>
    array (
      'path' => '/usr/share/webapps/owncloud/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 =>
    array (
      'path' => '/usr/share/webapps/owncloud/custom_apps',
      'url' => '/custom_apps',
      'writable' => true,
    ),
  ),
);

The Virtual Host Part from httpd-ssl.conf like that

<VirtualHost _default_:443>

#   General setup for the virtual host
DocumentRoot "/srv/http"
ServerName www.example.com:443
ServerAdmin you@example.com
ErrorLog "/var/log/httpd/error_log"
TransferLog "/var/log/httpd/access_log"

And owncloud.conf like that

<IfModule mod_alias.c>
    Alias /${TARGET_SUBDIR} /usr/share/webapps/owncloud/
</IfModule>

<Directory /usr/share/webapps/owncloud/>
Header always add Strict-Transport-Security "max-age=15768000; includeSubDomains; preload"
    Options FollowSymlinks
    AllowOverride all
    Require all granted
    php_admin_value open_basedir "/srv/http/:/home/:/tmp/:/usr/share/pear/:/usr/share/webapps/owncloud/:/etc/webapps/owncloud:/dev/urandom"
</Directory>

And a startServers.sh from the image

#!/usr/bin/env bash

if [ "$ENABLE_DAV" = true ] ; then
  cat >> /etc/httpd/conf/httpd.conf <<EOF
Alias /dav "/home/httpd/html/dav"

<Directory "/home/httpd/html/dav">
  DAV On
  AllowOverride None
  Options Indexes FollowSymLinks
  Require all granted
</Directory>
EOF

ownCloud log (data/owncloud.log)

The last 50 lines from the log are the same output

{"reqId":"e9QleU77evfFGkVmx574","remoteAddr":"xxx.xxx.xxx.xxx","app":"core","message":"Exception: {\"Exception\":\"Doctrine\\\\DBAL\\\\DBALException\",\"Message\":\"Failed to connect to the database: An exception occured in driver: SQLSTATE[HY000] [1862] Your password has expired. To log in you must change it using a client that supports expired passwords.\",\"Code\":0,\"Trace\":\"#0 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(429): OC\\\\DB\\\\Connection->connect()\\n#1 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(389): Doctrine\\\\DBAL\\\\Connection->getDatabasePlatformVersion()\\n#2 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(328): Doctrine\\\\DBAL\\\\Connection->detectDatabasePlatform()\\n#3 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(621): Doctrine\\\\DBAL\\\\Connection->getDatabasePlatform()\\n#4 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/db\\\/connection.php(135): Doctrine\\\\DBAL\\\\Connection->setTransactionIsolation(2)\\n#5 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/DriverManager.php(172): OC\\\\DB\\\\Connection->__construct(Array, Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOMySql\\\\Driver), Object(Doctrine\\\\DBAL\\\\Configuration), Object(Doctrine\\\\Common\\\\EventManager))\\n#6 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/db\\\/connectionfactory.php(118): Doctrine\\\\DBAL\\\\DriverManager::getConnection(Array, Object(Doctrine\\\\DBAL\\\\Configuration), Object(Doctrine\\\\Common\\\\EventManager))\\n#7 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/server.php(327): OC\\\\DB\\\\ConnectionFactory->getConnection('mysql', Array)\\n#8 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/3rdparty\\\/pimple\\\/pimple\\\/src\\\/Pimple\\\/Container.php(112): OC\\\\Server->OC\\\\{closure}(Object(OC\\\\Server))\\n#9 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/appframework\\\/utility\\\/simplecontainer.php(104): Pimple\\\\Container->offsetGet('DatabaseConnect...')\\n#10 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/server.php(762): OC\\\\AppFramework\\\\Utility\\\\SimpleContainer->query('DatabaseConnect...')\\n#11 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/db.php(42): OC\\\\Server->getDatabaseConnection()\\n#12 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/server.php(235): OC_DB::getConnection()\\n#13 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/3rdparty\\\/pimple\\\/pimple\\\/src\\\/Pimple\\\/Container.php(112): OC\\\\Server->OC\\\\{closure}(Object(OC\\\\Server))\\n#14 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/appframework\\\/utility\\\/simplecontainer.php(104): Pimple\\\\Container->offsetGet('AppConfig')\\n#15 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/server.php(701): OC\\\\AppFramework\\\\Utility\\\\SimpleContainer->query('AppConfig')\\n#16 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/util.php(410): OC\\\\Server->getAppConfig()\\n#17 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/util.php(343): OC_Util::loadVersion()\\n#18 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/defaults.php(52): OC_Util::getVersion()\\n#19 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/template.php(81): OC_Defaults->__construct()\\n#20 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/template.php(328): OC_Template->__construct('', 'exception', 'error', false)\\n#21 \\\/usr\\\/share\\\/webapps\\\/owncloud\\\/index.php(55): OC_Template::printExceptionErrorPage(Object(Doctrine\\\\DBAL\\\\DBALException))\\n#22 {main}\",\"File\":\"\\\/usr\\\/share\\\/webapps\\\/owncloud\\\/lib\\\/private\\\/db\\\/connection.php\",\"Line\":52}","level":3,"time":"2021-09-14T17:42:22+00:00","method":"GET","url":"\/index.php\/s\/AZ0Eeyp1QkXDyBC"}

I’m really running out of ideas and I don’t know where to look anymore. Do you see here vlt what I do not see? Thank you very much