Internal Server Error when trying to access users tab

user_management

#1

I downloaded and started the vmware version and wanted to create users. This is what I got when I clicked on the users option from the dropdown.

The server encountered an internal error and was unable to complete your request.

Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.

More details can be found in the server log.

Technical details
Remote Address: 172.17.42.1
Request ID: piZIeJfRnnAVjm6DPnJs


#2

Hi,

You are talking about the ownCloud appliance, right?

Can you tell me where you have downloaded it and when? Recently there has been a new release

Also, what are your network settings of your appliance?
I found that it's the best to set it to bridge mode


#3

Hi,

I'm experiencing just the same issue. Downloaded the recent OVA file from owncloud.org, yesterday) and imported that to my ESXi 6.0. Everything works fine except for the user settings menu option. In my case, the appliance has the IP 192.168.4.11, I access the web interface using the DNS name of the VM.

Unfortunately I'm not familiar with how docker works, so I have no idea how to read a corresponding log file, if any.


#4

Hi,

what do you mean by "everything works"?


#5

Well, I wanted to say that I didn't experience any other problem. The VM booted fine, after setting the required options I was able to use the web interface as well as synchronising appliances on other devices. The settings area is available, but when I, with the standard owncloud account, try to access the users settings (from the top right corner), I see that 'internal server error' o the blue earth-from-space photograph. It seems there is something with the underlying database, but I don't know enough about the docker technology to check internal logs etc. So I consider to start over, maybe that helps.


#6

Hey, I think I just solved it. owncloud had a problem resolving the name of the LDAP server.
What I didn't expect to find in the owncloud settings: The users are managed by the LDAP directory service of the host UCS system. This is strange because in the initial setup I think I had the choice between LDAP and local user database (I picked the last). Also, in UCS user list there is no owncloud user, only the Administrator.
The DNS name that was listed in Administration > Settings > User-Authentication > LDAP / Server could somehow not be resolved from inside the docker container (though, it does from my local LAN). So I changed it against the IP adress of the server and now the User settings screen is working :slight_smile:


#7

I wanted to write you about the LDAP Server, but I am glad you solved it yourself :slight_smile:


#8

Thanks for caring :slight_smile:


#9

Server configuration detail

Operating system: Linux 2.6.32-042stab127.2
Webserver:
Database: mysql 5.6.38
PHP version: 7.0.0
Owncloud version: 13.0.0 - 13.0.0.14
Updated from an older Nextcloud/ownCloud or fresh install:
Fresh Install
Where did you install Nextcloud from: Installation

Signing status

Array

List of activated apps

Are you using encryption:** yes


#10

There is no 13.0.0 ownCloud available.

But there is nextCloud in this version.

maybe you should write here:


#11

So my owncloud has been working fine for 2 days. But I changed the IP address of the vm. After changing it, I cant go inside the USERS settings anymore.

I also noticed that only Administrator username is inside the UCS user list.

so how do you correct the IP Address of the LDAP server, like where do you go specifically? And do I have to manually add again the user "owncloud" to the UCS user list and the other usernames that were previously working (and actually still currently working)?


#12

The users settings in ownCloud or in the univention management console?

Did you create other domain users?

Try in the ownCloud LDAP settings.

Or you could try to go in the UCM and there to enter the LDAP settings, and change there the DNS entry, that probably still has the old IP Address mapped to the domain name.


#13

cant go inside the USERS settings anymore.

The users settings in ownCloud or in the univention management console?

Sorry, I mean USERS Settings inside the Owncloud.
I can go inside the Users inside the UCS

I also noticed that only Administrator username is inside the UCS user list.

Did you create other domain users

When I first set the owncloud, i created the 2 other users inside the owncloud users page. After that, I just went inside UCS users page as well, and noticed that the 2 other usernames i created inside owncloud is also there, plus the username: owncloud. So i guess owncloud is using UCS's list of usernames. But now, when i check UCS users list, only the Administrator account is there. Not even the username "owncloud" is there.

I will try your suggestions in a bit.

Thank you


#14

do you mean this one?

of this one:

Because I meant the second one. User Authentication. There you can adjust the your LDAP server settings.


#15

It is the first one that I cannot go to.


#16

yeah. that's because you need to change the settings of the second one

Edit:

Tested. I started a Appliance at work, went home, changed the IP address, and could not access the users tab in ownCloud.

Went to user authentication, changed the domain name of the LDAP server to the new IP address, and it worked.


#17

Thank you very much! It is working now.

I am just a bit confused though, the server address when it was not working is my DDNS address, which I guess was there from the very start when it was first setup and worked from the start (I guess).

After changing the local IP of my VM (and thats when I lost access to USERS page), the same DDNS address was there, and that is the reason I did not touch it when I was looking around to troubleshoot my problem.

And after following your suggestion, I tried to change that DDNS address to the local IP address, and viola! the Users page is working again.

Anyway, the important thing for now is that it is working again. I still have to learn a lot in this.

Thank you for your help dmitry!


#18

Glad it worked out :slight_smile:


#19

you saved me a lot of frustration. thxs for letting us know


#20

Hi @telmi

May we know how you updated the ip address?

Thanks!