Internal server error with ldap autentication

Hi, I migrated our owncloud server to version 10.4.
It is linked to LDAP, but now, when a user wants to authenticate, the following error appears:##
after the error, if I give it an intro, it enters and validates with the user correctly.

Can you help me ?

Error Intern del Servidor

El servidor ha trobat un error intern i no pot finalitzar la teva petició.
Please contact the server administrator if this error reappears multiple times and include the technical details below in your report.
More details can be found in the server log.
Detalls tècnics

  • Adreça remota:
  • Sol·licitud ID: cRGF3rXsiJZprA7PFFOr

I tried to look for the log file to find the record that tells me (id), but I can’t find it

in the configuration section of the ldap, when verifying configuration and number of users I find 322 users. they are the right ones, but they do not appear to me in the section of users

Installation data:
Ubuntu(16.04.6 LTS)
PHP 7.2.30-1
Owncloud 10.4.1

“basic”: {
“date”: “Wed, 13 May 2020 10:30:04 +0000”,
“ownCloud version”: “”,
“ownCloud version string”: “10.4.1”,
“ownCloud edition”: “Community”,
“server OS”: “Linux”,
“server OS version”: “Linux ubuntu-owncloud 4.4.0-178-generic #208-Ubuntu SMP Sun Apr 5 23:45:10 UTC 2020 x86_64”,
“server SAPI”: “apache2handler”,
“webserver version”: “Apache/2.4.43 (Ubuntu)”,
“logged-in user”: “owncloud”
“stats”: {
“users”: {
“Database”: {
“count”: 1,
“seen”: 1,
“logged in (30 days)”: 1
“LDAP”: {
“count”: 2,
“seen”: 2,
“logged in (30 days)”: 1
“groups”: {
“OC\Group\Database”: 1,
“OCA\User_LDAP\Group_Proxy”: 1
“config”: {
“instanceid”: “ocmadm6kisld”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“datadirectory”: “/var/www/html/owncloud/data”,
“overwrite.cli.url”: “http://1REMOVED SENSITIVE VALUE/owncloud”,
“dbtype”: “mysql”,
“version”: “”,
“dbname”: “owncloud”,
“dbhost”: “localhost”,
“dbtableprefix”: “oc_”,
“logtimezone”: “UTC”,
“installed”: true,
“mail_smtpmode”: “smtp”,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_smtphost”: “REMOVED SENSITIVE VALUE”,
“mail_smtpsecure”: “ssl”,
“ldapIgnoreNamingRules”: false,
“loglevel”: 1,
“mail_smtpport”: “25”,
“memcache.local”: “\OC\Memcache\APCu”,
“memcache.locking”: “\OC\Memcache\Redis”,
“redis”: {
“host”: “localhost”,
“port”: 6379
“maintenance”: false
“integritychecker”: {
“passing”: true,
“enabled”: true,
“result”: []
“core”: {
“avatar_migration_completed”: “true”,
“backgroundjobs_mode”: “cron”,
“default_encryption_module”: “OC_DEFAULT_MODULE”,
“encryption_enabled”: “yes”,
“installedat”: “1463071933.9294”,
“lastcron”: “1588756244”,
“lastupdateResult”: “[]”,
“lastupdatedat”: “1589365774”,
“public_files”: “files_sharing/public.php”,
“public_webdav”: “dav/appinfo/v1/publicwebdav.php”,
“remote_caldav”: “dav/appinfo/v1/caldav.php”,
“remote_calendar”: “dav/appinfo/v1/caldav.php”,
“remote_carddav”: “dav/appinfo/v1/carddav.php”,
“remote_contacts”: “dav/appinfo/v1/carddav.php”,
“remote_dav”: “dav/appinfo/v2/remote.php”,
“remote_files”: “dav/appinfo/v1/webdav.php”,
“remote_webdav”: “dav/appinfo/v1/webdav.php”,
“shareapi_allow_public_notification”: “no”,
“umgmt_send_email”: “true”,
“umgmt_show_email”: “true”,
“umgmt_show_last_login”: “true”,
“umgmt_show_storage_location”: “true”,
“vendor”: “owncloud”

Check your owncloud.log for that ID, you can usually find it in your ownCloud data folder.

You migrated or you updated? If you migrated make sure all required modules are installed.
Also the error message you tried pasting doesn’t seem to be showing up, I only see two hashes (##)

What do you mean with, if I give it an intro?

From which ownCloud version did you upgrade from, where any system updates installed recently or PHP versions changed?

1 Like

Good morning, sorry for my English and thanks for the quick response.
I have already found the record, the attachment:

{"reqId":"cRGF3rXsiJZprA7PFFOr","level":3,"time":"2020-05-13T10:44:53+00:00","remoteAddr":"","user":"CD4CB575-8199-4D4A-8C9B-1F35F3B18135","app":"index","method":"GET","url":"\/owncloud\/index.php\/apps\/files\/","message":"Exception: {\"Exception\":\"OCP\\\\Files\\\\NotFoundException\",\"Message\":\"\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/html\\\/owncloud\\\/apps\\\/files\\\/lib\\\/Controller\\\/ViewController.php(134): OC_Helper::getStorageInfo('\\\/', false)\\n#1 \\\/var\\\/www\\\/html\\\/owncloud\\\/apps\\\/files\\\/lib\\\/Controller\\\/ViewController.php(207): OCA\\\\Files\\\\Controller\\\\ViewController->getStorageInfo()\\n#2 \\\/var\\\/www\\\/html\\\/owncloud\\\/lib\\\/private\\\/AppFramework\\\/Http\\\/Dispatcher.php(153): OCA\\\\Files\\\\Controller\\\\ViewController->index('', '', NULL, NULL)\\n#3 \\\/var\\\/www\\\/html\\\/owncloud\\\/lib\\\/private\\\/AppFramework\\\/Http\\\/Dispatcher.php(85): OC\\\\AppFramework\\\\Http\\\\Dispatcher->executeController(Object(OCA\\\\Files\\\\Controller\\\\ViewController), 'index')\\n#4 \\\/var\\\/www\\\/html\\\/owncloud\\\/lib\\\/private\\\/AppFramework\\\/App.php(100): OC\\\\AppFramework\\\\Http\\\\Dispatcher->dispatch(Object(OCA\\\\Files\\\\Controller\\\\ViewController), 'index')\\n#5 \\\/var\\\/www\\\/html\\\/owncloud\\\/lib\\\/private\\\/AppFramework\\\/Routing\\\/RouteActionHandler.php(47): OC\\\\AppFramework\\\\App::main('ViewController', 'index', Object(OC\\\\AppFramework\\\\DependencyInjection\\\\DIContainer), Array)\\n#6 \\\/var\\\/www\\\/html\\\/owncloud\\\/lib\\\/private\\\/Route\\\/Router.php(342): OC\\\\AppFramework\\\\Routing\\\\RouteActionHandler->__invoke(Array)\\n#7 \\\/var\\\/www\\\/html\\\/owncloud\\\/lib\\\/base.php(916): OC\\\\Route\\\\Router->match('\\\/apps\\\/files\\\/')\\n#8 \\\/var\\\/www\\\/html\\\/owncloud\\\/index.php(54): OC::handleRequest()\\n#9 {main}\",\"File\":\"\\\/var\\\/www\\\/html\\\/owncloud\\\/lib\\\/private\\\/legacy\\\/helper.php\",\"Line\":585}"}

I made an update, it came from the version, I add again:
owncloud 9.0.2
Ubuntu(14.04.4)14.04 LTS
PHP 5.5.9-lubuntu4.29

The error message is the one attached below, ‘internal server error’.
I mean that even though it gives the error, if you reload the page, you can log in with the user, then it even appears in the users section.

I attach the configuration report in the following message as it is very long and does not allow me to add it in this one.

Thank you very much for your help.

I can’t add it all since it takes up more characters than it allows, can I send the whole file through some other channel?

When did you do what? And what where the immediate steps before you started having trouble?

Thanks for posting the older version information.

Did you just recently upgrade from 14.04? Please detail the system state before the most recent upgrade that started giving you problems. (Basically the last known good system configuration)

Can you roll back? And if yes, does the error go away?

This again is basically the same question. We need to understand what you did to get where you are to figure out a way out…

I’ve increased your trust level in this forum, so I hope you should be able to just post it here now.

1 Like


I have the old version installed since 2014 with LDAP link and working properly.
The organization decided to expand the use of Owncloud by adding the ONLYOFFICE package to be able to work collaboratively.
When I checked the package I saw that I needed to upgrade the owncloud version, and when I checked the requirement for the new version I saw that I needed to upgrade the rest of the components.

Platform Options
Operating System • Ubuntu 16.04 and 18.04
Database • MySQL or MariaDB 5.5+
Web server • Apache 2.4 with prefork and mod_php
PHP Runtime • 5.6, 7.0, 7.1, and 7.2

We were working with virtual machines, so I cloned the machine, changed the ip settings, and checked that it was still working.
Then I started with the update. First I updated ubuntu, then apache and finally php.
I also changed the access to https and enabled hsts following the oncloud security recommendations.
When updating the owncloud I saw that the ldap app I was using so far (LDAP user and group backend 0.8.0) was not working with the new version, so I removed it and put (LDAP Integration 0.15.1).
It also gave me database integrity errors, but I deleted all the files and moved on (sudo -u www-data php / var / www / htlm / owcloud / occ maintenance: repair).
At this time, I do not see any errors or alerts in the oncloud security and configuration warnings.

Good morning,

I’m sorry, but I still can’t upload the file, it has about 242000 characters and only allows me to upload 32000.
I’ll pass you the LDAP part, if any other part is needed let me know please.

        "id": "user_ldap",
        "name": "LDAP Integration",
        "summary": "Integrate LDAP user directories",
        "licence": "AGPL",
        "author": "J\u00f6rn Friedrich Dreyer, Tom Needham, Juan Pablo Villafa\u00f1ez Ramos, Dominik Schmidt and Arthur Schiwon",
        "version": "0.15.1",
        "types": [
        "documentation": {
            "admin": "https:\/\/\/server\/latest\/admin_manual\/configuration\/user\/user_auth_ldap.html"
        "category": "integration",
        "screenshot": "https:\/\/\/owncloud\/screenshots\/master\/user_ldap\/ownCloud-app-ldap-user-management.jpg",
        "dependencies": {
            "lib": "ldap",
            "owncloud": {
                "@attributes": {
                    "min-version": "10.4",
                    "max-version": "10"
        "namespace": "User_LDAP",
        "settings": {
            "admin": "OCA\\User_LDAP\\AdminPanel"
        "commands": [
        "use-migrations": "true",
        "info": [],
        "remote": [],
        "public": [],
        "repair-steps": {
            "install": [],
            "pre-migration": [],
            "post-migration": [],
            "live-migration": [],
            "uninstall": []
        "background-jobs": [],
        "two-factor-providers": [],
        "_cached": true,
        "groups": null,
        "active": true,
        "internal": false,
        "removable": true,
        "preview": "\/owncloud\/apps\/user_ldap\/img\/app.svg",
        "previewAsIcon": true,
        "appconfig": {
            "cleanUpJobOffset": "200",
            "enabled": "yes",
            "has_memberof_filter_support": "1",
            "home_folder_naming_rule": "",
            "installed_version": "0.15.1",
            "last_jpegPhoto_lookup": "0",
            "ldap_agent_password": "***REMOVED SENSITIVE VALUE***",
            "ldap_attributes_for_group_search": "",
            "ldap_attributes_for_user_search": "",
            "ldap_backup_host": "",
            "ldap_backup_port": "",
            "ldap_base": "dc=olesam",
            "ldap_base_groups": "dc=olesam",
            "ldap_base_users": "dc=olesam",
            "ldap_cache_ttl": "600",
            "ldap_configuration_active": "1",
            "ldap_display_name": "samaccountname",
            "ldap_dn": "cn=Administrador,cn=Users,dc=olesam",
            "ldap_dynamic_group_member_url": "",
            "ldap_email_attr": "mail",
            "ldap_experienced_admin": "0",
            "ldap_expert_username_attr": "",
            "ldap_expert_uuid_group_attr": "",
            "ldap_expert_uuid_user_attr": "",
            "ldap_group_display_name": "samaccountname",
            "ldap_group_filter": "(|(cn=Usuarios del dominio))",
            "ldap_group_filter_mode": "0",
            "ldap_group_member_assoc_attribute": "member",
            "ldap_groupfilter_groups": "Usuarios del dominio",
            "ldap_groupfilter_objectclass": "",
            "ldap_host": "192.168.0.x.x",
            "ldap_login_filter": "(&(&(|(objectclass=person))(|(|(memberof=CN=Usuarios del dominio,CN=Users,DC=olesam)(primaryGroupID=513))))(samaccountname=%uid))",
            "ldap_login_filter_mode": "1",
            "ldap_loginfilter_attributes": "",
            "ldap_loginfilter_email": "0",
            "ldap_loginfilter_username": "1",
            "ldap_nested_groups": "0",
            "ldap_network_timeout": "2",
            "ldap_override_main_server": "",
            "ldap_paging_size": "500",
            "ldap_port": "389",
            "ldap_quota_attr": "",
            "ldap_quota_def": "",
            "ldap_tls": "0",
            "ldap_turn_off_cert_check": "0",
            "ldap_user_display_name_2": "",
            "ldap_user_filter_mode": "0",
            "ldap_user_name": "samaccountname",
            "ldap_userfilter_groups": "Usuarios del dominio",
            "ldap_userfilter_objectclass": "person",
            "ldap_userlist_filter": "(&(|(objectclass=person))(|(|(memberof=CN=Usuarios del dominio,CN=Users,DC=olesam)(primaryGroupID=513))))",
            "signed": "true",
            "types": "authentication",
            "use_memberof_to_detect_membership": "1"

        "app": "user_ldap",
        "version": "20180606135121"

    "curl": {
        "cURL support": "enabled",
        "cURL Information": "7.47.0",
        "Age": "3",
        "Features": null,
        "AsynchDNS": "Yes",
        "CharConv": "No",
        "Debug": "No",
        "GSS-Negotiate": "No",
        "IDN": "Yes",
        "IPv6": "Yes",
        "krb4": "No",
        "Largefile": "Yes",
        "libz": "Yes",
        "NTLM": "Yes",
        "NTLMWB": "Yes",
        "SPNEGO": "Yes",
        "SSL": "Yes",
        "SSPI": "No",
        "TLS-SRP": "Yes",
        "HTTP2": "No",
        "GSSAPI": "Yes",
        "KERBEROS5": "Yes",
        "UNIX_SOCKETS": "Yes",
        "PSL": "No",
        "Protocols": "dict, file, ftp, ftps, gopher, http, https, imap, imaps, ldap, ldaps, pop3, pop3s, rtmp, rtsp, smb, smbs, smtp, smtps, telnet, tftp",
        "Host": "x86_64-pc-linux-gnu",
        "SSL Version": "OpenSSL\/1.0.2g",
        "ZLib Version": "1.2.8"

    "ldap": {
        "LDAP Support": "enabled",
        "RCS Version": "$Id: 3839f871a91c293a52322c63329c68db23a0290a $",
        "Total Links": "0\/unlimited",
        "API Version": "3001",
        "Vendor Name": "OpenLDAP",
        "Vendor Version": "20442",
        "SASL Support": "Enabled",
        "ldap.max_links": "Unlimited"