Intl extension error when creating a SMB external storage


#1

Hello all,

Fresh install with the following specs:
CentOS 7.4.1708
PHP Version 7.1.11
owncloud 10.0.3

When I try to create a SMB external storage, the share won't connect and I have this message in the log:

... "method":"GET","url":"\/owncloud\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/owncloud\/lib\/composer\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18"}...

I can connect to the share directly using smbclient from the command line.

Intl and libsmblcinet extensions are installed (I think) since PHP -i gives:

Internationalization support => enabled
version => 1.1.0
ICU version => 50.1.2
ICU Data version => 50.1

libsmbclient

Version => 0.9.0

httpd restarted and I even tried to reboot.
I'm a bit lost...
Any help appreciated!

Thank you.

lamazzi


#2

Do you have php-libsmbclient installed? https://doc.owncloud.org/server/10.0/admin_manual/configuration/files/external_storage/smb.html


#3

As I have stated php -i gives:

libsmbclient

Version => 0.9.0

EDIT:To use sure I've tried this:

<?php
echo smbclient_version ( );
?>

it returns: 0.9.0


#4

I think running php -i on the command line isn't a good replacement for checking if your webserver (where owncloud is running) has loaded the module correctly. Once the webserver has loaded that module correctly the message from your logfile will disappear.