Invalid host name for certificate (Desktop client)

Apologies if there is a file explaining this. I searched owncloud central and help files but maybe not the right one.

Actual behaviour

At login when the Opencloud client tries to connect I get this Notice:

Untrusted Certificate

8< –
Cannot connect securely to cloud-xxxx.yourownnet.cloud:
The host name did not match any of the valid hosts for this certificate
with Certificate collabora07.yourownnet.cloud
8<
At the bottom I have the option to trust this certificate anyway.

Expected behaviour

At login Opencloud just connects and starts syncig (sometimes asks for my credentials).
Tell us what should happen

Actual behaviour

Tell us what happens instead

Steps to reproduce

  1. Login

Client configuration

Client version:

Operating system: Ubuntu 18.04

OS language: English

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only): Owncloud

Installation path of client: /home/rwigle/bin/Nextcloud

Client Version: Version 2.6.0stable (build 20190927).

Seems you are you not using the ownCloud client??

1 Like

Check your SSL installation for cloud-xxxx.yourownnet.cloud with ssldecoder.org, a fast check is enough.
In the section “Certificate for ‘cloud-xxxx.yourownnet.cloud’” there is “Common Name” and “Subject Alternative Names”.

I would suspect that the certificate installed is only for ‘collabora07.yourownnet.cloud’ and ‘cloud-xxxx.yourownnet.cloud’ is neither in the “Common Name” nor the “Subject Alternative Names”.

If you have a Let’s Encrypt Certificate you should easily be able to regenerate it with the additional “Subject Alternative Names”. Otherwise you might have to order a new certificate from your provider, or think about installing a wildcard certificate.

1 Like

Thanks @eneubauer! Regenerating certificates is beyond my skill set but ssidecoder gave me something to include in my query to my ?provider?.

bin/Nextcloud/Nextcloud-2.6.0-x86_64.AppImage But I don’t think that’s the problem.