iOS 12 calendar iOS stock via caldav

Happy New Year, guys!

Any suggestions what to do if you don’t use a hosted/public OC server? Mine is at home and inaccessible from the Internet, so any CA can’t validate the cert request, which means no “official” ssl cert.

For my use case, it is sufficient if the synchronisation happens only in my private network and this can happen unencrypted from my point of view

Did any of you try https with a self-signed certificate?


Self-signed certificates work.
iOS will prompt a warning that the certificate is not trusted. Check the details and if you’re convinced its your certificate, trust it.

Warning: We lost all calendar entries from the iOS device that had not been synced to Owncloud! Back them up somewhere else before the first https synchronization

Now, let’s see when Apple/Google/Mozilla stop accepting self-signed certs…

1 Like


i refused to put ios12 on my devices for some time for exactly the reason that some unpredictable undocumented features suddenly appear. however this is what works for me

IOS 9.3.5 (very old IPad mini) & IOS 11.4.1 (IPhone SE) & Owncloud & working letsencrypt ssl-certificate
https://[your server address]/remote.php/caldav/principals/[your user name]/

I have found this server address syntax on my old mini IPad and gave it a try. To my surprise this worked, after trying all the stuff on the outdated documentary.

Hope you find this useful

Update on 9/18/2019 - still not able to make ios connect - what I’ve notices is that CalDavSync (what I’ve been testing with on Outlook) shows owncloud.log entries that use PROPFIND and iOS seems to use the same things with “REPORT” as a method. Is it possible that somehow that is confusing things?


Read the thread you need a valid ssl certificate

I certainly have and here are the generalized details about the certificate below. Can you tell me why iOS would find that insufficient? Certificates are issued by cPanel and backed by Sectigo (Formerly known as Comodo). All of their certificates are accepted by Apple, according to the VPS provider. I checked the site with this:

Please don’t just tell me to get another - can you help me understand why this one wouldn’t be sufficient?

In order to log into the site from a browser, https is required and the site shows SSL required.

Certificate ID: blackholeinc_net_f2b6c_887b1_1576713599_942d4f4c32ca34952c56dd887cce3dd7
Domains: *

Don’t use Apache i am using lighttpd . Does log show any errors ? Maybe if you set up a test account i can try

Hey, Chaco - I’m silling to add a user for you, but need an email. If you don’t want to post it here, reach out to me @


Did you force your connection to 443 ssl

1 Like

Yes. And I’m now using letsencrypt ssl


So why when i connected to your url did not force me to ssl ?

1 Like

I’m unable to login to without using SSL. I do not know how to force it to not let you try I’d adjust that if you can provide guidance.


Also check data/owncloud.log

1 Like

That’s informative. I modified the top level .htaccess in my public_html directory and it still lets me get to (although logins do not work). When I go to I can successfully log in.

Since live below public_html (in 2817f/bhi) I modified that .htaccess file as well. There was already some existing rewrite rules, but they appeared to be for other things. I added the https rewrite in the “custom” section. However, it still behaves as above.

More ideas or direction? What should I be looking for in the logfile?

I appreciate the help as this part of web maintenance is still very new to me.


Can you show settings

1 Like

And, I think I solved the force https for

1 Like

Here’s how I attempt to set this up on my iPhone 7+ with iOS 13.1.2:

  1. Go to Passwords and Accounts
  2. Select Add Account
  3. Select Other
  4. Select Add CalDAV Account
  5. For Server, enter
  6. For User Name, enter josef
  7. For Password, enter my password (with which I can log into the website from Chrome on Windows)
  8. For Description, enter BHICAL
  9. Select next
  10. Wait while the phone says “Verifying”
  11. Get this pop-up: “Cannot Connect Using SSL. Do you want to try setting up the account without SSL?”
  12. Select Cancel
  13. Get this pop-up: “Calendar Account. Unable to verify account information.”
  14. Select OK
  15. Select Advanced Settings
  16. Verify that Account URL says “
  17. Verify that Use SSL is selected (green)
  18. Type 443 for the Port
  19. Go back to Caldav
  20. Select Next
  21. Get the same pop up as Step 11.
  22. Hit cancel
  23. Get the same popup as step 13.
  24. Recheck Advanced settings. They’re still the same as 16-18.
  25. Hit Save, on the off chance that it will work. :wink:
  26. It warns me it may not work.
  27. Go to the Calendar App
  28. Select Calendars
  29. Surprise - I see my calendar.

I did from scratch on iOS 13.1.2 and had no problems

And, surprise! It’s now working. Thanks for your guidance on things to do.