iOS 12 calendar iOS stock via caldav


#1

iOS calendar was syncing fine on 11.4.1
Now that 12 is out it wont connect anymore

Using latest stable OC
iOS 12

Nothing in ownCloud.log


#2

We did a short investigation and found out that this is a problem on Apple side. They changed the behaviour of sending the credentials in iOS 12. We will involve Apple to clarify that and find an solution.


#3

Related: Caldav sync issues with ios 12 beta


#4

No is not

That old phone was not running beta 12. As commented above this is an issue with iOS 12 which needs to be addressed in OC


#5

I performed a quick test and added the ownCloud 10.0.10 calendar account to “BusyCal” on the same iOS 12 device, an there it syncs without problem.


#6

Not for me. Just tried


#7

Excuse me but are we talking about the same stuff here?

I think you are trying to use stock iOS calendar and @michaelstingl was using another app.

Or am I wrong?

also @michaelstingl could you describe how you got it working? Thanks


#8

i am using stock calendar in ios i thought busycal was the name he gave the calendar :slight_smile:


#9

https://www.busymac.com/


#10

is there a fix in sight


#11

I think best advice is to check the GitHub issue.

Developers look, work, and document their process there.


#12

This sounds like its going to take a while

Will look for workarounds


Since MacOS Mojave 10.14 error in Calendar under ownCloud 10.0.10.4
#13

Are you connecting to a owncloud server with http or HTTPS?
Self signed cert or Something real?


#14

Well thanks for checking back .

Prior i had self signed but yesterday was able to get real letsencrypt ssl . When i retried bingo it worked with ssl.


#15

I too have the problem after iOS upgrade to 12.0.1 with oC 10.0.10 with http:// access.

The CalDav works fine with Thunderbird the only problem appears to be with iOS devices and verifying the account login.

Hope there is a fix/patch soon not being able to sync calendars among our iOS devices is pretty frustrating.

(Username changed to “foo”)
ownCloud Log:
25T21:19:05+00:00",“remoteAddr”:“75.127.163.58”,“user”:"–",“app”:“core”,“method”:“POST”,“url”:"/owncloud/index.php/login",“message”:“Login failed: ‘foo’ (Remote IP: ‘75.127.163.58’)”}
{“reqId”:“oknkCT7n4Rs8DMl1xGZ7”,“level”:2,“time”:“2018-10-25T21:19:12+00:00”,“remoteAddr”:“75.127.163.58”,“user”:"–",“app”:“core”,“method”:“POST”,“url”:"/owncloud/index.php/login?user=foo",“message”:“Login failed: ‘foo’ (Remote IP: ‘75.127.163.58’)”}

and full log reporting:
8482b8c27dc45057fc73ef554fc53f01aa9086b98138a0315a85db887543982db6bd2b08b637aa5797a5d7ebbfe5e9f9349c5a71a03a47f06fa5f61b21c06b45 does not exist"}
{“reqId”:“lBG8AnEpPXyhaZEFOyIy”,“level”:0,“time”:“2018-10-29T14:15:03+00:00”,“remoteAddr”:“192.168.10.254”,“user”:“foo”,“app”:“OC\Authentication\Token\DefaultTokenProvider::updateToken”,“method”:“PROPFIND”,“url”:"/owncloud/remote.php/caldav/calendars/jfoo/inbox/",“message”:“updating token 75332, last check is now 1540822502”}
{“reqId”:“lBG8AnEpPXyhaZEFOyIy”,“level”:0,“time”:“2018-10-29T14:15:03+00:00”,“remoteAddr”:“192.168.10.254”,“user”:“foo”,“app”:“OC\Authentication\Token\DefaultTokenProvider::getToken”,“method”:“PROPFIND”,“url”:"/owncloud/remote.php/caldav/calendars/foo/inbox/",“message”:“token 8482b8c27dc45057fc73ef554fc53f01aa9086b98138a0315a85db887543982db6bd2b08b637aa5797a5d7ebbfe5e9f9349c5a71a03a47f06fa5f61b21c06b45 does not exist”}
{“reqId”:“5yjRdLf1JDF25qp0AZE2”,“level”:0,“time”:“2018-10-29T14:15:03+00:00”,“remoteAddr”:“192.168.10.254”,“user”:“foo”,“app”:“OC\Authentication\Token\DefaultTokenProvider::updateToken”,“method”:“PROPFIND”,“url”:"/owncloud/remote.php/caldav/calendars/jon.a/inbox/",“message”:“updating token 75332, last check is now 1540822502”}
{“reqId”:“5yjRdLf1JDF25qp0AZE2”,“level”:0,“time”:“2018-10-29T14:15:03+00:00”,“remoteAddr”:“192.168.10.254”,“user”:“foo”,“app”:“OC\Authentication\Token\DefaultTokenProvider::getToken”,“method”:“PROPFIND”,“url”:"/owncloud/remote.php/caldav/calendars/foo/inbox/",“message”:"token


#16

Hey,

from what i read so far the issue is not caused by ownCloud so there probably can’t be a fix from ownCloud side:

It seems that the new Apple releases (iOS / macOS) are requiring a valid SSL setup and deny to send login credentials it none is provided by your server.

So to fix this issue it seems you need to get active and rework the SSL setup of your web server and the sync of your calendars should work automatically afterwards.


#17

Tom42,
I saw it solved the problem for one user but did not link it directly to Apple… getting a valid SSL cert running on small home server is either costly or a PITA. The only game in town on the cheap is Letsencrypt. Which from pasted experience is not simple to do.

Thank you for your observation and putting 2 & 2 together for me.

Regards


#18

I think lets encrypt is one of the most simple methods you can find with plenty of documentation out there


#19

I can confirm, iPhones stopped synching CardDav and CalDav via Davical to our Office 2016 based backend after the IOS 12 upgrade.

At first we leaned towards an Apache2 issue, but after reading your notes here our focus has changed to IOS 12.

Our actual error is " AH01630: client denied by server configuration: /var/www/html/" this is an Apache2 error. It suggests that the server is configured incorrectly and is denying the client.

But it makes more sense that it’s Apple mangling the credentials to the server since all none iPhone IOS 12 clients are synching fine.

Hope this helps someone. Will provide update if we have success going the route of applying ssl certs to the connection.

Thanks


#20

Here is what I learned: Synchronisation (CalDAV & CardDAV) from Owncloud to IOS 10 (maybe even 11) works just fine without SSL (https), but in IOS 12 it does not. But if the connection supports SSL, it works just fine. What is a bit misleading on Apples part here, that even in IOS 12 it lets you choose between unencrypted and encrypted, without informing that the first just won’t work.
What I use: OC 10.0.9.5 on a Strato hosted server.
I entered as credentials in IOS just the domain to where Owncloud is located, not the full path, even though it says so in the out of date User Manual here:

https://doc.owncloud.org/server/10.0/user_manual/pim/sync_ios.html

So if I just use as server: “example.com” IOS will find the full path by itself, IF that domain is being redirected to the folder in which OC in located in. It did NOT work with “example.com/owncloud

And remember, it is important that there is a working SSL certificate assigned to the domain “example.com”.