iOS Aoo Can't View Files

help

#1

Please help us by providing the following info.

Steps to reproduce
1. Fire up app
2. Log in
3. Navigate to File
4. Touch File

Expected behaviour
File should load ... for instance, if it's an image, the image should be displayed

Actual behaviour
Animated "loading" graphic spins forever, never loading file.

Mobile client configuration
Client OS (iOS, Android, ...):
Client version: iOS - iPad Pro 12.9" iOS Version 10.2

Server configuration
Operating system: iOS
Web server: CentOS 7
Database: Mariadb 5.5.52
PHP version: 5.46
ownCloud version (see ownCloud admin page): 9.1
Updated from an older ownCloud or fresh install: fresh
ownCloud log (data/owncloud.log):

Special configurations (external storage, external authentication, reverse proxy, server-side-encryption): Server-side encryption


#2

Sorry, after a couple of hours of banging at it, I resolved this. There was a problem with my Mysql user not having GRANT perms in one of the tables. Not sure why it effected the app and not the browser, but when I fixed the perms, the app worked as expected, so this is solved.

Great code by the way.

Thank you.