iOS app does not finish processing

Steps to reproduce

  1. Take a picture of the document with “Scan document”.
  2. Save it.

Expected behaviour

The file is successfully uploaded and the process is complete.

Actual behaviour

Users can wait for hours for the process to finish. The progress circle keeps spinning endlessly. The file size is irrelevant at this point. Even files of a few KB can cause this problem. At this time, the upload is actually completed on the server side.

At this time, the user cannot stop the file by touching it, so the user has to wait. Users can restart the app, but this will not solve the problem.

The solution I know.

The server will delete the relevant file and the iOS user will restart the app.
The file will then be uploaded to the server again, and the iOS user will stop after the upload process is complete.


iOS 14.0.1, ownCloud(server) 10.6.0, ownCloud(iOS) 11.4.4

Workaround:

  • Enable Diagnostics in Settings
  • Swipe-left the stuck entry on the Status screen
  • Open Info screen and tab “Reschedule” button

Please reply if it worked.

“Real” fix planned for January.

1 Like

Thanks for the workaround information.
That solved it for me. Users have been able to complete their uploads smoothly and without any problems after that process.

Version 11.4.5 with a fix was just released:

Please give it a try and report back.

1 Like