IOS app - file downloads fail on wifi but not cellular

Steps to reproduce

  1. Open iPhone Owncloud client app while connected to a wifi network
  2. Try to download an individual file in a synchronised folder
  3. Download fails
  4. Turn off wifi and repeat Step 2 using cellular connection
  5. Download succeeds

Expected behaviour

The file should be downloaded

Actual behaviour

The file is not downloaded and I get error messages such as the following:
What should I do?
Uploads from the iPhone Photo Library work ok
CORS has no domains white-listed.
Thanks, folks!

Server configuration

Web server:


PHP version:

ownCloud version:
Storage backend (external storage):


iOS version:
11.7.0 Build 197

ownCloud app version:

Device model:
iPhone 11 IOS 14.7.1


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Tell us what could be improved:

Are only some files are affected? Or all files?

Does it work in other WiFi? Problem specific to your WiFi?

1 Like

H Michael
Thanks for your prompt response.
I’ve tried it on two wifi networks in my work premises. These are on the same domain as the desk PCs that run the Windows OC client and, from which, I connect to the OC server via the web interface.
I will try the IOS client from my Home wifi tonight and report back.
At Home, the Windows OC client on my wifi laptop works fine.

Hi Michael
I had the same result (error 31) when connecting to the wifi at home. Connecting via cellular worked as expected.
I noticed that, when trying to get JPEGs on the wifi, the client seems to download a small, low-res thumbnail.
When trying to download PDFs the error message appears and then the spinning download wheel carries on - thinking it is downloading - until I tap on Status and cancel it.
I cannot think of anything unusual in the setup of the phone so I would be amazed if I am the only person with this issue.
The OC server instance was installed via Softaculous and my server-side knowledge is pretty poor so I haven’t fiddled with anything there.
If you have any suggestions I would be very grateful.

Please urgently solve this error


Are there only two of us using the IOS Owncloud who have experienced this?
If anyone has this experience please let me know by reply.