iOS Client - App Crash after update 3.7.2

apps
ios

#1


Steps to reproduce

  1. Make sure iOS 11.2.2 is installed (probably not necessary)
  2. Here is what I did on my iPad Pro (10.7 inch)
    2.1 I updated to OC-App-Version 3.7.2
    2.2 I exported some notes from the native notes app as follows
    2.3 pick a note and use the export button on the top right corner
    2.4 use button create PDF
    2.5 in the created PDF use the export button on the top right corner
    2.6 use the button copy in "ownCloud"
    2.7 screen shows the blue ownCloud-Cloud symbol
    2.8 after about 1 second iPad returns to homexcreen

  3. Here is what I did with my iPhone (SE iOS 11.2.2)
    3.1 Uploaded a PDF from Mail to ownCloud (before installing newest App-Update)
    3.2 Upload was successful
    3.3 Installed the OC-App Update to 3.7.2
    3.4 followed all steps from 2.2 to 2.7 adapting them to my iPhone

Expected behaviour

Normally ownCloud App should proceed with a dialog that asks me where to upload the exported note and I should be able to choose a folder of my ownCloud folder structure and click on "save here" or "upload here".

Actual behaviour

As mentioned above app crashes after showing the blue cloud symbol. Killing the app in Multitasking mode and/or restart the device did not help.
Delft user from device and newly login did have no effect.

Server configuration

If this is needed, please reply to this topic. I checked in the app that transferring a document between folders and accessing it is working. So I think there is no problem with the server or the connection to it.
Web server:

Database:

PHP version:

ownCloud version:
ownCloud 7.0.4+dfsg-4~deb8u4 (Debian) (stable)

Storage backend (external storage):

Client

11.2.2

3.7.2

Iphone SE and iPad Pro 10.7 inch from 2017(both)

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Tell us what could be improved:


#2

Thanks for reporting. I think this problem fits with the following one, already reported in github:


#3

I am also having this issue with multiple devices. We are running Owncloud on 100 iPads and any of them that have updated are having this issue.


#4

@rfrederick: I tried the workaround on GitHub mentioned b @jesmrec. It works, thanks for that. And YES that seems to be the same issue.


#5

The workaround works for me some of the time. Sometimes I can't select another folder and sometimes it zips the file. It just worked better with the copy to owncloud. This is a big issue for us.


#6

The issue is already fixed. We will release a new version soon. Thanks for your patient.


#7

Any timeline on the new version?


#8

During this or next week should be available @rfrederick


#9

If you would like to test it, please contact us at apps@owncloud.com and reference this issue, Thanks for your feedback


#10

Update on the update?


#11

A bit delayed, but it is coming, Sorry for the inconveniences


#12

I really need this update to be released. I have 100 MDM deployed iPads to sales staff and the work around is buggy at best. Most times you can not select a folder so the staff member has to go in and move the file after upload and sometimes for some reason it zips the file.


#13

I have the same trouble with IOS 3.7.2 than rfrederik
The workaround works, but we are waiting for the fix...
Did you know when the update will be published?
Thank you


#14

We have already available a beta version, if you want to try it, please contact us here apps@owncloud.com and reference this issue. Thanks for your patience and understanding