iOS sync caldav and carddav sync


I am pretty new to owncloud and self-hosting. I have setup a bluehost server and added a subdomain for my owncloud server. It installed fine and I am able to sync my contacts and calendar on my laptop with KDE Kontact. However, I am not able to make it work on iOS.

What I have tried is to add another account on iOS under Settings → Contacts → Accounts → Add Account.

I always get a “Account verification failed”, however I can log in with Safari pointing to remote.php/dav.

Can somebody help me diagnose this problem?

Detailed instructions here:

1 Like

I followed these instructions without success. On the troubleshooting site, I looked into the well-known addresses and could see that I can access them from the browser.


i think it could help if more details like where the data is put in, in which form and similar is provided. I think this could help that others are better able to help.

So this is the error message I got on my phone (iPhone 7, iOS 15.8):

This form can be accessed under Settings → Contacts → Account → Add Account → Other → Add CardDav Account

In the server field I entered

For the owncloud Server, I did the following:

  • I added a submain in cPanel, which gave me a ~/ folder.
  • I ssh into the server, cd ~/ into to the dir and ran wget The archive I extracted with unzip
  • I changed the root of the domain to ~/ And changed the php Version to 7.4 with a cPanel tool. The latter created a ~/ file pointing to the correct php Version.
  • I added a mySQL database with the cPanel tool, and ran the setup of owncloud pointing my browser to
  • Lastly, I added my first user philipp
  • I could also add contacts sync in KDE using the server address

Can you log in from your mobile using the browser?

Yes, that works perfectly:

What is perfect with a white screen? I’d expect either the login screen or the files app screen.

Oh I logged into to see if the CalDAV thing is really working. Here is the the screen after I logged in on

OK, then this seems to work. But the header is somewhat irritating, at least for me as non-apple guy.

I assume you did follow the advices from the docs.

If the iPhone is unable to verify the account information perform the following steps:

  • Select OK.
  • Select Advanced Settings.
  • If your server does not support SSL, make sure Use SSL is set to OFF.
  • Change port to 80.

Go back to account information and click Save.

Oh I see! So this error is not actually an error! I see it works now. Thank you so much!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.