Issue after Upgrading from Debian 8 to 9


#1

Hi everyone,
after i have upgraded to Debian 9 i’m having this issue when i connect to my OW server.
I foud that the issue is the PHP version, so i switch it to the 7.0 but nothing solved.
I also tried to upgrade to OW 9 .0,removing calendar and contacts, without good results. Any ideas?

Thanks in advice for your help!

this is the error message when i attempt to connect:

Exception occurred while logging exception: Failed to connect to the database: An exception occured in driver: could not find driver
#0 /var/www/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(992): OC\DB\Connection->connect()
#1 /var/www/owncloud/lib/private/DB/Connection.php(210): Doctrine\DBAL\Connection->executeUpdate(‘PRAGMA read_unc…’, Array, Array)
#2 /var/www/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(623): OC\DB\Connection->executeUpdate(‘PRAGMA read_unc…’)
#3 /var/www/owncloud/lib/private/DB/Connection.php(145): Doctrine\DBAL\Connection->setTransactionIsolation(2)
#4 /var/www/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/DriverManager.php(172): OC\DB\Connection->__construct(Array, Object(Doctrine\DBAL\Driver\PDOSqlite\Driver), Object(Doctrine\DBAL\Configuration), Object(Doctrine\Common\EventManager))
#5 /var/www/owncloud/lib/private/DB/ConnectionFactory.php(146): Doctrine\DBAL\DriverManager::getConnection(Array, Object(Doctrine\DBAL\Configuration), Object(Doctrine\Common\EventManager))
#6 /var/www/owncloud/lib/private/Server.php(521): OC\DB\ConnectionFactory->getConnection(‘sqlite3’, Array)
#7 /var/www/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC{closure}(Object(OC\Server))
#8 /var/www/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(111): Pimple\Container->offsetGet(‘DatabaseConnect…’)
#9 /var/www/owncloud/lib/private/ServerContainer.php(87): OC\AppFramework\Utility\SimpleContainer->query(‘DatabaseConnect…’)
#10 /var/www/owncloud/lib/private/Server.php(1192): OC\ServerContainer->query(‘DatabaseConnect…’)
#11 /var/www/owncloud/lib/private/Server.php(398): OC\Server->getDatabaseConnection()
#12 /var/www/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC{closure}(Object(OC\Server))
#13 /var/www/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(111): Pimple\Container->offsetGet(‘AppConfig’)
#14 /var/www/owncloud/lib/private/ServerContainer.php(87): OC\AppFramework\Utility\SimpleContainer->query(‘AppConfig’)
#15 /var/www/owncloud/lib/private/Server.php(1121): OC\ServerContainer->query(‘AppConfig’)
#16 /var/www/owncloud/lib/private/Server.php(575): OC\Server->getAppConfig()
#17 /var/www/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC{closure}(Object(OC\Server))
#18 /var/www/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(111): Pimple\Container->offsetGet(‘AppManager’)
#19 /var/www/owncloud/lib/private/ServerContainer.php(87): OC\AppFramework\Utility\SimpleContainer->query(‘AppManager’)
#20 /var/www/owncloud/lib/private/Server.php(1391): OC\ServerContainer->query(‘AppManager’)
#21 /var/www/owncloud/lib/private/legacy/app.php(346): OC\Server->getAppManager()
#22 /var/www/owncloud/lib/private/legacy/app.php(110): OC_App::getEnabledApps()
#23 /var/www/owncloud/lib/base.php(579): OC_App::loadApps(Array)
#24 /var/www/owncloud/lib/base.php(997): OC::init()
#25 /var/www/owncloud/index.php(54): require_once(’/var/www/ownclo…’)
#26 {main}


#2

You probably haven’t installed and activated all required php modules:
https://doc.owncloud.org/server/10.0/admin_manual/installation/source_installation.html#php-extensions


#3

i’ve installed all php modules but still not working
same errors


#4

php -m please - make sure the correct php executable in case multiple are installed


#5

[PHP Modules]
bz2
calendar
Core
ctype
curl
date
dom
exif
fileinfo
filter
ftp
gd
gettext
gmp
hash
iconv
imagick
imap
intl
json
ldap
libsmbclient
libxml
mbstring
mcrypt
mysqli
mysqlnd
openssl
pcntl
pcre
PDO
pdo_mysql
pdo_pgsql
pdo_sqlite
pgsql
Phar
posix
readline
Reflection
session
shmop
SimpleXML
smbclient
sockets
SPL
sqlite3
ssh2
standard
sysvmsg
sysvsem
sysvshm
tokenizer
wddx
xml
xmlreader
xmlwriter
xsl
Zend OPcache
zip
zlib

[Zend Modules]
Zend OPcache

i switched from php5 to php 7.0


#6

ok - sqlite is there.

did you restart apache?


#7

yes i’ve restarted apache


#8

Hey, i think “php -m” is not a full replacement for checking if the module is enabled within the web server or am i wrong?


#9

It is enough as long as the php config for cli and apache are identical.
Butt according to the thread it is not …

@ilnerdchuck you are obviously facing issue with your php setup. Please have a closer look to your php configuration.