Issue own cloud server

hosting

#1

Hi,
I’ve installed own cloud server. It works fine, but there are a lot of issue:

php non sembra essere configurato correttamente per interrogare le variabili d’ambiente di sistema. Il test con getenv(“PATH”) restituisce solo una risposta vuota.
Controlla la documentazione di installazione↗ per le note di configurazione di php e la configurazione del tuo server, in particolare quando utilizzi php-fpm.
Il blocco del file transazionale dovrebbe essere configurato per utilizzare un metodo di blocco basato sulla memoria, non il lento metodo predefinito basato sul database. Vedi la documentazione :arrow_upper_right: per ulteriori informazioni.
Alcuni file non hanno superato il controllo di integrità. Ulteriori informazioni su come risolvere questo problema sono disponibili nella nostra documentazione. (Elenco dei file non validi… / Nuova scansione…)
L’intestazione HTTP “X-XSS-Protection” non è configurata come “1; mode=block”. Questo è un potenziale rischio di sicurezza o di riservatezza dei dati e noi consigliamo di modificare questa impostazione.
L’intestazione HTTP “X-Content-Type-Options” non è configurata come “nosniff”. Questo è un potenziale rischio di sicurezza o di riservatezza dei dati e noi consigliamo di modificare questa impostazione.
L’intestazione HTTP “X-Robots-Tag” non è configurata come “none”. Questo è un potenziale rischio di sicurezza o di riservatezza dei dati e noi consigliamo di modificare questa impostazione.
L’intestazione HTTP “X-Frame-Options” non è configurata come “SAMEORIGIN”. Questo è un potenziale rischio di sicurezza o di riservatezza dei dati e noi consigliamo di modificare questa impostazione.
L’intestazione HTTP “X-Download-Options” non è configurata come “noopen”. Questo è un potenziale rischio di sicurezza o di riservatezza dei dati e noi consigliamo di modificare questa impostazione.
L’intestazione HTTP “X-Permitted-Cross-Domain-Policies” non è configurata come “none”. Questo è un potenziale rischio di sicurezza o di riservatezza dei dati e noi consigliamo di modificare questa impostazione.
Sei connesso a questo sito tramite HTTP. Ti suggeriamo vivamente di configurare il tuo server per richiedere invece l’utilizzo del protocollo HTTPS, come descritto nei nostri consigli sulla sicurezza.

my .htaccess is:

SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1 RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1 RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION SetEnvIfNoCase Authorization "(.+)" HTTP_AUTHORIZATION=$1 # Add security and privacy related headers Header set X-Content-Type-Options "nosniff" Header set X-XSS-Protection "1; mode=block" Header set X-Robots-Tag "none" Header set X-Frame-Options "SAMEORIGIN" Header set X-Download-Options "noopen" Header set X-Permitted-Cross-Domain-Policies "none" SetEnv modHeadersAvailable true

Let browsers cache CSS, JS files for half a year

<FilesMatch “.(css|js)$”>
Header set Cache-Control “max-age=15778463”

Let browsers cache WOFF files for a week

<FilesMatch “.woff$”>
Header set Cache-Control “max-age=604800”

php_value always_populate_raw_post_data -1 php_value upload_max_filesize 513M php_value post_max_size 513M php_value memory_limit 512M php_value mbstring.func_overload 0 php_value default_charset 'UTF-8' php_value output_buffering 0 SetEnv htaccessWorking true php_value upload_max_filesize 513M php_value post_max_size 513M php_value memory_limit 512M php_value mbstring.func_overload 0 php_value default_charset 'UTF-8' php_value output_buffering 0 SetEnv htaccessWorking true RewriteEngine on RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}] RewriteRule ^\.well-known/host-meta /public.php?service=host-meta [QSA,L] RewriteRule ^\.well-known/host-meta\.json /public.php?service=host-meta-json [QSA,L] RewriteRule ^\.well-known/carddav /remote.php/dav/ [R=301,L] RewriteRule ^\.well-known/caldav /remote.php/dav/ [R=301,L] RewriteRule ^remote/(.*) remote.php [QSA,L] RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.* - [R=404,L] RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/.* RewriteRule ^(?:\.|autotest|occ|issue|indie|db_|console).* - [R=404,L] AddType image/svg+xml svg svgz AddEncoding gzip svgz DirectoryIndex index.php index.html AddDefaultCharset utf-8 Options -Indexes ModPagespeed Off

DO NOT CHANGE ANYTHING ABOVE THIS LINE

ErrorDocument 403 /core/templates/403.php
ErrorDocument 404 /core/templates/404.php

Can you help me please?


#2

Hey, did you had a look at the documentation mentioned in the messages?