Issue syncing from server to client

sync

#1

Steps to reproduce

1.Install Univention 4.2.3 virtualbox
2.Setup AD with external storage to Shared drive
3. Install Desktop client

Expected behaviour

Tell us what should happen
Files should sync from server and visa versa

Actual behaviour

Tell us what happens instead
Not syncing from server but will sync at account creation, If created simple text file on server then create one on local owncloud the files sync as it should.

Server configuration

Operating system:
Debian 64bit, This is Univertion for virtualbox applicence
Web server:
apache2 I think
Database:
I think MySQL - unsure
PHP version:
Unknow what evers current on install.
ownCloud version: (see ownCloud admin page)
10.0.3.3
Updated from an older ownCloud or fresh install:
Fresh install
Where did you install ownCloud from:
website
Signing status (ownCloud 9.0 and above):

Are you using external storage, if yes which one: local/smb/sftp/...
yes, smb
Are you using encryption: yes/no
no
Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/...
active directory

Client configuration

Browser:
MS Edge
Operating system:
Windows 10

Logs

Web server error log

05-10 20:52:59:039 [ info sync.connectionvalidator ]:	** Application: ownCloud found:  QUrl("http://208.81.196.17/owncloud")  with version  "10.0.3" ( "10.0.3.3" )
05-10 20:52:59:041 [ info sync.connectionvalidator ]:	QUrl("http://208.81.196.17/owncloud") has server version "10.0.3.3"
05-10 20:52:59:042 [ info sync.accessmanager ]:	6 "PROPFIND" "http://208.81.196.17/owncloud/remote.php/webdav/" has X-Request-ID "4e1b2cd3-b9f2-4cc5-bf6b-55753ed20894"
05-10 20:52:59:043 [ info sync.networkjob ]:	OCC::PropfindJob created for "http://208.81.196.17/owncloud" + "/" "OCC::ConnectionValidator"
05-10 20:52:59:235 [ info sync.networkjob.propfind ]:	PROPFIND of QUrl("http://208.81.196.17/owncloud/remote.php/webdav/") FINISHED WITH STATUS QNetworkReply::NetworkError(NoError) ""

#2

This looks quite outdated, maybe you can try to update to a recent version via the Univention App Center?


#3

I’ve tried but it still states that this is the most recent version. But if you go in owncloud dashboard it shows there’s an update and if I try it fails to update via web updater app.

Thank you for the help.


#4

I should rephrase what’s happening.

The client connects to the server. The client downloads the share folder complete. If I add a file to the server the client doesn’t download the new file or folder. If I select force Sync that doesn’t do anything.

But if I create a new file on the local machine the client then uploads the files then downloads the newly created files from the server.

Basically the client only downloads from the server at first setup then never downloads anything new unless I create a file locally.

Thank you
Brock


#5

Hey,

i understood you in this case. :slight_smile: But i think no one can guarantee that this is just caused by a possible bug / issue in this outdated version which is already solved in a newer one.

Thats why its always suggested to stay at the recent releases instead of keeping outdated versions running. I'm just not sure why you don't get an update offered as it seems the App Center of Univention already has 10.0.7: :confused:


#6

So I wonder if I download the VirtualBox image if I’ll get uns 4.3 Instead of 4.2 and. Have the updated version of onecloud.

I downloaded the version I have from owncloud.com

Edit: I’m downloading and going to see what happens. I’ll report back.

Thank you


#7

Well the uns version is the same 4.2. I did try 4.3 but would fail to join the active directory.


#8

hello,

I managed to get it to upgrade using the web updater app. but im stuck in maintenace mode

Ive tried this but keep getting permission denied. Im logged in as a root user and in a ssh terminal.

univention-app shell owncloud
su www-data
cd /var/www/owncloud
./occ upgrade
./occ maintenance:mode --off


#9

i managed to get maintenance mode off but the upgrade failed saying some marketplace apps need to be manually updated.

Not sure how to do that so ill look into it.

sorry for all the updates.
Brock


#10

ok I have gotten all the apps I use and now running owncloud 10.0.08 and client version is 2.4.1 but the issue still happing with the client not downloading the newly created files from the server.

I will also note I can see the created files on the web version. This is a external storage that is add to owncloud and added to the owncloud client.


#11

Maybe its related to the external storage? I had read found the following a few weeks ago:

https://doc.owncloud.org/server/latest/admin_manual/configuration/files/external_storage_configuration_gui.html#detecting-files-added-to-external-storages


#12

Hi Tom,

yeah I saw too. but When using the command in occ file:scan --all it doesn’t seem like its touching the files of the external share.

This is a share that ive attached to owncloud and using login with creds, saved in session allows owncloud to use the Active Directory folder permissions. I havent tried the Ajax cron but it looks like that only run if a user goes to the owncloud website. which kinda defeats the purpose of the desktop client I guess maybe ? who knows

This is the only hurdle I have with the syncing of file changes from the server to the client other wise its works great besides that.

Thank you
Brock


#13

Hello

I’ve found using WebDAV does what I want without using the desktop client. Would there be any draw back from using it?


#14

Thats perfectly valid if sufficient for your use case! Alternative is to setup WND Drive with Listener, but thats a real project and part of the Enterprise Edition.
Recommend a WebDAV Client like Cyberduck for any Windows users as the Win implementation of WebDAV has its shortcomings …


#15

What kind of short comings? Just wondering


#16

Plenty. Authentication needs to be repeated frequently. MS Office has a different WebDAV stack and will ask again for authentication while you can’t use the one in the OS anymore. Quite slow, etc.
It has not been fun to use for any serious user till now. Occassionally: fine. Mac and Linux WebDAV work perfectly. Oh and prior to Windows 8 it does not work at all.