Issues saving through Office apps


#1

Hi,

I'm a computer technician and I have a weird bug and need your help. Me and another user in the office are using Owncloud deskptop client and moved both DOCUMENT and PICTURE folder under the Owncloud folder. This is usefull to allow us to quickly save to our Owncloud folder using the DOCUMENTS and PICTURES default shortcuts. When I do that, I get an error message when saving a file to either of those locations. (errors were detected while saving....)

I remember this was working not long ago, but I can't say if started failing after an Office update or Owncloud Desktop client update.

Anyone else stuck with this ?


#2

check if the path for document and picture are still in the owncloud folder

you can post the logs from the sync client in here, maybe someone can help you


#3

Thanks for the follow up, dmitry. To clarify, we don't have issues syncing files. we have an issue when trying to save from Excel or Word to those folders.

Both paths are still in the Owncloud folder and syncing properly.


#4

Exactly same issue with the new version 10.0.2 . Was OK with the previous 9 version.

Any help would be highly appreciated.


#5

This is not caused by Owncloud X, since we are using Owncloud 8. I believe this is caused by either the Owncloud Desktop Client or MS Office. I'll try to downgrade my client and post my results.


#6

I've tried Desktop Client 2.3.0 and 2.24 and the problem persist. So this has to be caused by Office or some Windows update. @HerveCH, are you having this issue under Windows 10 only ?


#7

Just tried with Release 2.3.3 rc2 and this is not fixing it either.


#8

I tried unbinding my DOCUMENTS and PICTURES folder from OwnCloud and the issue persisted. So basically, the only fact that the file is saved to the Owncloud folder is enough to cause problem. Saving to the same folder, under another filename doesnt help either.


#9

I downgraded back to owncloud 9. Using win7 pro and family + Win 10 and and its running well.
I do not use the Desktop client, i added owncloud as a network drive for all pc.


#10

The preliminary changelog of the upcoming owncloud release is mentioning a fixe for network drives on windows 10: https://github.com/owncloud/core/blob/stable10/CHANGELOG.md


#11

Quite odd that we are having the same issue under much different circumstances. I had two other users complain about this problem. It just started happening on their PCs this week.


#12

Here's another something I noticed. The problem is only present the current Word and Excel format (.DOCX and .XLSX). If I do the same thing using .DOC and .XLS extensions, it works w/o any issues.


#13

Some more.
Any office app ( .doc . xls ) is on read only mode when you open it from Owncloud.
To be able to open and save, I created a short cut as a network drive in my Win 7 / Win 10.


#14

Have you checked both the client and core bugtrackers for this issue?


#15

@HerveCH Great tip !!! How did you come up with this ? I mapped Z: drive to my OwnCloud folder, had both DOCUMENTS and PICTURE locations pointed to Z: and everything is fine now. This is a weird bug and I can't wait to see who's behind this.


#16

Let's go deeeper in this ...

For any shared XLS / XLSM file, you would need to open excel first then open your file.
Not doing so ( opening your file by a doubleclick ) will open it as read only mode.


#17

Still not resolved on my side. What about you ?


#18

it is working fine..
Did you tried to mapp it on Win as a Z drive ?
Are your file / folder not too big ? ( Max size is 300mb )


#19

Mapping a drive works, I'm just wondering if you had any luck fixing the issue. I guess we are still looking/waiting to know who's responsible and if we can expect a real fix soon.


#20

Cannot fix such, being only a user ...:smirk: