Issues with upgrade from 8.2.8 to 9.0.5: Undetermined Error during Integrity check

possible_bug
help

#1

I have reviewed all the posts on the integrity check issues with upgrade to 9, and none of them seem to solve my issue. I should also add that I have been using OwnCloud for about 6 years, but I have minimal tech savvy.

I started with version 8.1.1, then upgraded to 8.1.10, and the upgraded to 8.2.8. All those upgrades worked fine. Then tried to upgrade from 8.2.8 to 9.0.5 and the installation stalls.

I have been manually upgrading by extracting files to my desktop machine and then FTP'ing to Dreamhost where I have been running owncloud.

Steps to reproduce
1. Delete all OwnCloud files on the Dreamhost server except config and data folders
2. Go to url for the owncloud installation
3. Click "Start" to begin the upgrade
4. Page updates to show progress of upgrade "Preparing update, Set log level to debug, Turned on maintenance mode, Checking whether database schema can be updated, Checked database schema update, checking update of apps, checled database schema update for apps, updating database schems, updated database, Starting code integrity check."
5. Page then stays on integrity check step for 15 or 20 minutes. Then says "An error occurred. Please reload page."
6. Reload page then generates page stating that site is in maintenance mode.
7. Change config file to mainatenance_mode => false, and reload.
8. Goes through same cycle starting at step 2.

Expected behaviour
The expected behavior is that the upgrade completes, and is functional.

Actual behaviour
"An error occurred" message pops up. The owncloud.log file provides no additional information.

Server configuration
Operating system:
Web server: DreamHost
Database: MySql
PHP version: 5.6
ownCloud version (see ownCloud admin page): 8.2.8 upgrading to 9.0.5
Updated from an older ownCloud or fresh install: Updated from existing install
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808):

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): none

Integrity status for oC9+

Login as admin user into your ownCloud and access: cannot log into OwnCloud as upgrade fails
http://example.com/index.php/settings/integrity/failed
paste the results here.

#2

Hi,

the best thing what you probably can do here is to report this directly to https://github.com/owncloud/core/issues where such issues during upgrades belongs to.


#3

Thanks for the suggestion.

Turns out I solved the problem. I had an old version of OwnCloud archived with my current version. Not a good idea I realize, The archived version was nested on the server as owncloud/owncloud. Again, not a great idea but it had not caused a problem previously.

When I deleted the archived owncloud version, the upgrade worked fine.

I will close the ticket.


#4

Hi,

you still might want to report this as a bug to the issue tracker. I don't think that the integrity check should fail like that?