It's show error message when I upgrade from 9.1.0 to 9.1.1

update_issue
updater
update
9.1.x
help

#1

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release: https://owncloud.org/changelog/

Steps to reproduce
1. login in to owncloud server
2. click updater
3.

Expected behaviour
It's should to update

Actual behaviour
It's should to update

Server configuration
Operating system: Debian 7
Web server: apache2 2.2.22
Database: Mysql 5.5.52
PHP version: 5.4.45
ownCloud version (see ownCloud admin page): 9.1.0
Updated from an older ownCloud or fresh install: 9.1.0
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

{"reqId":"Imdft\/CexQs7IlsgulrZ","remoteAddr":"192.168.2.1","app":"core","message":"Invalid request to occ controller. Details: \"Web executor is not allowed to run from a host 192.168.2.1\"","level":2,"time":"2016-11-02T06:50:35+00:00","method":"POST","url":"\/index.php\/occ\/config:list","user":"--"}

Integrity status for oC9+

No errors have been found.

Update failed.It's show
e

[UnexpectedValueException] e

Could not parse a response for config:list. Please check if the current shell user can run occ command. Raw output:

Not allowed


#2

Have you noticed the patches provided here: https://central.owncloud.org/t/patches-for-known-update-issues-from-version-9-0-4-9-0-5-9-1-0-9-1-1/3549/6

Personally i think it doesn't worth to mess around with patches. Just do the manual update without the updater app like explained here:

https://doc.owncloud.org/server/latest/admin_manual/maintenance/manual_upgrade.html


#3

I have use patch.But it's will get error when I use updater:
cURL error 35: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

I also use manual update
sudo -u vu2003 php occ upgrade
The vu2003 is occ owner.
It's say my owncloud is already latest version.
But it's always 9.1.0 version and not to 9.1.1.And updater always show 9.1.1 version can update.
How to fix it?


#4

Please read and follow the instructions at the posted link.