Jaimangously large file size transfer

10

#1

So I’m trying to figure out how rsync some files over to the owncloud server and get them to show up. I tired creating a file in the $datadirectory/$user/files directory and then ran the occ files:scan. But nothing showed up. Any ideas?

Why rsync? Because the files are huge. An average of about 40GB per file. Aside from bluehost somehow not allowing me upload files that are over a 1GB via the desktop client, the file size is larger than the 16GB that the owncloud documentation states for large file transfers.

If it helps, I do eventually plan on creating “guest” authenticated FTP account for people to download the files for specific directories as well.

In short, “secure” layman friendly large file distribution is the goal.


#2

I assume you don’t transfer the files as the www-data user, right?

copy - give the web server user the ownership - files:scan

This is the right order.


#3

Yes and no.

The files are owned by the same user as the other files; not just the core files. It’s bluehost shared hosting and they run everything as my regular account.

Am I dropping it in the right location for it to get picked up? I notice there’s caching and an upload directory.


#4

You need to give the web server the right permissions in order to your file to appear.


#5

Meh… Apparently I had chmod 777 the file for it show up.


#6

So, apparently I’m having the same issue if the OC is in a sub-directory or got moved to a sub-directory.

If OC is installed at root htdocs then it works after changing the permissions. But, that doesn’t seem to work in the sub-directory.


#7

have you tried the -R option?


#8

Yarp… on the $user/files/bigstuff directory.