Keine Datenbanktreiber (SQLite, MYSQL, oder PostgreSQL) installiert

help

#1

Hi,

I installed OC9 (with MYSQL, php 7.0, apache2 and phpmyadmin on Raspbian 8).
After generating a database with my phpmyadmin I get the following error message:

Keine Datenbanktreiber (SQLite, MYSQL, oder PostgreSQL) installiert.

PHP-Module wurden installiert, werden aber als noch fehlend gelistet?
Bitte fragen Sie Ihren Server-Administrator zum Neustart des Webservers.

I checked a lot of things in different forums, but I can't solve this problem.

Can anybody help me? What information do you need?
Thanks a lot.


#2

There is an installation documentation available at [1] explaining which database drivers are required. How to install these depends on your used linux distro and you can follow some generic tutorials available on the net how to install and enable these.

[1] https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html#prerequisites


#3

Hi,

I already know your target link and tried to find a solution last days, too.
But I tried again:

php -m | grep -i pdo_mysql

shows this result

pdo_mysql

So I see, the mysql-modul is already installed, but it didn't work.
I furthermore followed this link and installed the following modules and migrated my mysql database to Maria-db, but it didn't help to solve my problem.

apt-get install apache2 mariadb-server libapache2-mod-php7.0
apt-get install php7.0-gd php7.0-mysql php7.0-curl
apt-get install php7.0-intl php7.0-mcrypt php-imagick
apt-get install php7.0-zip php7.0-xml php7.0-mbstring

Nothing changes, the error code is still the same.
Has anybody else a solution?


#4

You can't use php -m on command line to check if the needed modules are loaded within your webserver. Those are two completely different things.

Use a phpinfo instead to see if the PDO and pdo_mysql drivers are loaded.


#5

OK, I checked with phpinfo.php


#6

Has nobody an idea how I can solve this problem?


#7

This should imply that the database connection is working. My PDO drivers also include sqlite (even though I'm not using a sqlite database), can you post the mysql*-section as well?


#8

Hay Hay @oesel was war jetzt letztendlich das Problem? Wie hast du es behoben?

Hay Hay @oesel Can you explan how to solve the problem ?