Killed process php

Hello!
Works constantly Oom killer and kills php-processes.
RAM 16 Gb
SWAP 16 Gb
CPUs 8
There are 2 cron-tasks for users www-data:
*/15 * * * * php -f /var/www/html/owncloud/cron.php
0 */4 * * * php /var/www/html/owncloud/occ user:sync -m disable “OCA\User_LDAP\User_Proxy”
This process /var/www/html/owncloud/cron.php is triggered Oom killer.
Help fix this error


oomlog.txt (2.7 KB)
cron.php.txt (5.9 KB)

###Server configuration
Operating system:
“user_ldap” 0.9.1
Operating system: Ubuntu Server 18.04 LTS
Web server:Apache/2.4.29
Database:mariaDB 10.1.34
PHP version:PHP 7.2
ownCloud version: ownCloud 10.0.10 (stable)
Updated from an older ownCloud or fresh install:
Special configuration (external storage - nas, external authentication- ldap, reverse proxy - no, server-side-encryption-no):

Hi domnich,

before you start investigating, I’d recommend to upgrade your ownCloud to the latest version, since you are still using 10.0. Especially, but not only, in 10.4 there were several improvements regarding background jobs (ie cron) memory consumption. (Search https://owncloud.com/changelog/server/ for ‘memory’)

If, after having upgraded, you still experience the OOM issue please provide a list of enabled apps and the owncloud.log around the timestamp when the OOM occured.

1 Like

Do you need to follow the sequence of versions when updating, or can you go straight to version 10.6?

For any ownCloud version it is safe to upgrade to the latest minor version, so 10.0 -> 10.6 is fine for you.

1 Like