Kontakte App: Probleme mit Gruppen und Labels


#1

Hallo,

ich wollte heute mit meinen Kontakten von der iCloud umziehen und alles in die Kontakte-App der ownCloud verschieben. Dabei fiel mir auf, dass die Synchronisation Gruppen irgendwie nicht funktioniert. Wenn ich unter Mac OS X eine Gruppe anlege, erscheint sie bei ownCloud als Kontakt. Wenn ich bei ownCloud eine neue Gruppe anlege, erscheint diese gar nicht unter Mac OS X. Gibt es dafür eine Lösung? Ich habe hier leider nur 3-4 Jahre alte Einträge gefunden, die dieses Problem beschreiben, leider ohne Lösung.

Außerdem sind die Labels der angelegten Felder nicht immer richtig. Eine unter OS X angelegte Kontaktadresse mit E-Mail (Arbeit), wird unter ownCloud zu Internet Work statt zu Arbeit. Wenn ich dann den Kontakt in der Cloud bearbeite (neue zus. E-Mail angelegt, Typ Arbeit) und erneut synce, sind bei OS X fast alle bis dahin richtigen Labels falsch. Das gerade in der Cloud angelegte E-Mail wird unter OS X korrekt zugewiesen (also auch Label Arbeit). Nun sind aber nahezu alle anderen Labels falsch. So steht die unangetastete private E-Mail auf einmal auf INTERNET,HOME,pref. Weitere Label, wie das der eingetragenen Telefonnummern stehen auf CELL,PREF oder HOME,VOICE.

Mache ich etwas falsch? Hat jemand einen Tipp wie man das unter Mac OS X zum laufen bekommt?

MAC OS X Kontakte (El Capitain)
ownCloud (9.0.4)
Contacts App (1.3.1.0)

Grüße, Vincent


#2

Für die Gruppen würde ich einfach einen Report auf github.com/owncloud/contacts/issues aufmachen. Ich bin hier nicht sicher, wie das im cardDAV-standard geregelt ist und wie sich owncloud und OS X dazu verhält. Eventuell lässt sich das Verhalten von OS X berücksichtigen.

Mit den Labels würde ich auch einfach ein Ticket aufmachen. OS X scheint zwar die Labels auf Deutsch anzuzeigen aber intern in Englisch zu verarbeiten. Vielleicht sollte das Owncloud auch so handhaben??


#3

Für die Gruppen-Probleme unter OS X gibt es sogar schon 2 Reports:



#4

Ich habe heute gesehen, dass es ein Update der Kontakte-App auf 1.4.0 gibt. Die Owncloud ist mittlerweile in der Version 9.1 und ich habe gehofft, dass die Probleme mit der neuen Version der Kontakte nun vielleicht behoben ist. Leider nicht. Das Verhalten ist nach wie vor ziemlich identisch zu meiner ersten Beschreibung. In dem Bugtracker Eintrag scheint sich auch nichts zu tun, so dass ich das wohl weiterhin am Mac nicht nutzen kann.

Weiß jemand zufällig, ob das bei Next Cloud funktioniert? Dann könnte man ja dahin umsteigen.

Grüße, Vincent


#5

Die Kontakte-App ist noch die gleiche, da hilft dir der Umstieg derzeit nicht weiter. Du könntest höchstens versuchen zu recherchieren, wie es sich mit Gruppen und CardDAV verhält und wie das von owncloud bzw. OS X unterstützt wird. Mit Geld könntest du versuchen, das Thema für Entwickler interessanter zu machen:
https://www.bountysource.com/issues/36222995-creating-a-group-under-osx-creates-an-entry-under-contacts


#6

Ich habe genau das gleiche Problem auf meinem Android Smartphone. Habe auf Android-Seite mehrere Apps zum synchronisieren ausprobiert (DavDroid und co), überall das gleiche Problem.
Benutze oC 9 auf eigenen Server


#7

Bitte erstelle einen neuen Thread und fülle das template aus, welches beim erstellen eines neuen Threads angezeigt wird.